aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pytest-checkdocs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-pytest-checkdocs/Makefile')
-rw-r--r--devel/py-pytest-checkdocs/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/devel/py-pytest-checkdocs/Makefile b/devel/py-pytest-checkdocs/Makefile
index 0a7d1b8bf1e4..54ace689857f 100644
--- a/devel/py-pytest-checkdocs/Makefile
+++ b/devel/py-pytest-checkdocs/Makefile
@@ -1,24 +1,30 @@
-# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-
PORTNAME= pytest-checkdocs
-PORTVERSION= 2.6.0
+PORTVERSION= 2.12.0
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Check the README when running tests
+WWW= https://github.com/jaraco/pytest-checkdocs
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0.15:textproc/py-docutils@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jaraco.functools>=0:devel/py-jaraco.functools@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pep517>=0:devel/py-pep517@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=56:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=3.4.1:devel/py-setuptools-scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0.15,1:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jaraco.packaging>=9.5:devel/py-jaraco.packaging@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-black>=0.3.7:devel/py-pytest-black@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-enabler>=1.3.0:devel/py-pytest-enabler@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-flake8>=0:devel/py-pytest-flake8@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-mypy>=0.9.1:devel/py-pytest-mypy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}types-docutils>=0:devel/py-types-docutils@${PY_FLAVOR}
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USES= python
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes