aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt5-test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-qt5-test/Makefile')
-rw-r--r--devel/py-qt5-test/Makefile31
1 files changed, 0 insertions, 31 deletions
diff --git a/devel/py-qt5-test/Makefile b/devel/py-qt5-test/Makefile
deleted file mode 100644
index abc94ff2c92c..000000000000
--- a/devel/py-qt5-test/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-PORTNAME= test
-PORTREVISION= 3
-CATEGORIES= devel python
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Python bindings for the Qt5 toolkit, QtTest module
-
-CONFIGURE_ARGS= --enable QtTest
-PYQT_DIST= yes
-
-USES= gl python:3.5+ pyqt:5 qt:5
-USE_GL= gl
-USE_PYQT= sip_build core_run widgets_run
-USE_PYTHON= concurrent flavors py3kplist
-USE_QT= core gui testlib widgets \
- buildtools_build qmake_build
-
-OPTIONS_DEFINE= API DEBUG
-OPTIONS_DEFAULT=API
-OPTIONS_SUB= yes
-
-API_DESC= Install QtTest API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
-API_CONFIGURE_OFF= --no-qsci-api
-API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
-DEBUG_CONFIGURE_ON= --debug --trace
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtTest.so
-
-.include <bsd.port.mk>