aboutsummaryrefslogtreecommitdiff
path: root/devel/rapidfuzz-cpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rapidfuzz-cpp/Makefile')
-rw-r--r--devel/rapidfuzz-cpp/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/rapidfuzz-cpp/Makefile b/devel/rapidfuzz-cpp/Makefile
new file mode 100644
index 000000000000..29d6580e3c04
--- /dev/null
+++ b/devel/rapidfuzz-cpp/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= rapidfuzz-cpp
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.0.4
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Rapid fuzzy string matching in C++ using the levenshtein distance
+WWW= https://github.com/maxbachmann/rapidfuzz-cpp
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= catch2>0:devel/catch2
+
+USES= cmake:testing compiler:c++17-lang
+
+CMAKE_TESTING_ON= RAPIDFUZZ_BUILD_TESTING
+
+USE_GITHUB= yes
+GH_ACCOUNT= maxbachmann
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>