aboutsummaryrefslogtreecommitdiff
path: root/devel/rlwrap
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rlwrap')
-rw-r--r--devel/rlwrap/Makefile7
-rw-r--r--devel/rlwrap/distinfo6
-rw-r--r--devel/rlwrap/pkg-plist6
3 files changed, 13 insertions, 6 deletions
diff --git a/devel/rlwrap/Makefile b/devel/rlwrap/Makefile
index f65048ebfbb5..ebb64be9f625 100644
--- a/devel/rlwrap/Makefile
+++ b/devel/rlwrap/Makefile
@@ -1,9 +1,9 @@
# Created by: ijliao
PORTNAME= rlwrap
-DISTVERSION= 0.44
+DISTVERSION= 0.45.2
CATEGORIES= devel
-MASTER_SITES= https://github.com/hanslub42/rlwrap/releases/download/${DISTVERSION}/
+MASTER_SITES= https://github.com/hanslub42/rlwrap/releases/download/v${DISTVERSION}/
MAINTAINER= gamato@users.sf.net
COMMENT= Readline wrapper
@@ -14,6 +14,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= autoreconf python readline shebangfix
PYTHON_NO_DEPENDS= yes
SHEBANG_GLOB= *.py
+SHEBANG_FILES= filters/dissect_prompt \
+ filters/handle_sigwinch \
+ filters/makefilter
python_OLD_CMD= "/usr/bin/env python3"
GNU_CONFIGURE= yes
diff --git a/devel/rlwrap/distinfo b/devel/rlwrap/distinfo
index bff97756f10e..d9f91616fee1 100644
--- a/devel/rlwrap/distinfo
+++ b/devel/rlwrap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611167981
-SHA256 (rlwrap-0.44.tar.gz) = cd7ff50cde66e443cbea0049b4abf1cca64a74948371fa4f1b5d9a5bbce1e13c
-SIZE (rlwrap-0.44.tar.gz) = 321590
+TIMESTAMP = 1623879763
+SHA256 (rlwrap-0.45.2.tar.gz) = 9f8870deb46e473d21b5db89d709b6497f4ef9fa06d44eebc5f821daa00c8eca
+SIZE (rlwrap-0.45.2.tar.gz) = 335015
diff --git a/devel/rlwrap/pkg-plist b/devel/rlwrap/pkg-plist
index 32ff4c045122..0965ac77b3d9 100644
--- a/devel/rlwrap/pkg-plist
+++ b/devel/rlwrap/pkg-plist
@@ -11,15 +11,18 @@ man/man3/RlwrapFilter.3pm.gz
%%DATADIR%%/filters/count_in_prompt
%%DATADIR%%/filters/count_in_prompt.py
%%DATADIR%%/filters/debug_null
+%%DATADIR%%/filters/dissect_prompt
+%%DATADIR%%/filters/edit_history
%%DATADIR%%/filters/ftp_filter
%%DATADIR%%/filters/ftp_filter.py
%%DATADIR%%/filters/handle_hotkeys
%%DATADIR%%/filters/handle_hotkeys.py
-%%DATADIR%%/filters/handle_sigwinch.py
+%%DATADIR%%/filters/handle_sigwinch
%%DATADIR%%/filters/history_format
%%DATADIR%%/filters/listing
%%DATADIR%%/filters/logger
%%DATADIR%%/filters/logger.py
+%%DATADIR%%/filters/makefilter
%%DATADIR%%/filters/null
%%DATADIR%%/filters/null.py
%%DATADIR%%/filters/outfilter
@@ -33,3 +36,4 @@ man/man3/RlwrapFilter.3pm.gz
%%DATADIR%%/filters/simple_macro
%%DATADIR%%/filters/template
%%DATADIR%%/filters/unbackspace
+