aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-pygments.rb
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-pygments.rb')
-rw-r--r--devel/rubygem-pygments.rb/Makefile6
-rw-r--r--devel/rubygem-pygments.rb/distinfo5
-rw-r--r--devel/rubygem-pygments.rb/files/patch-gemspec11
3 files changed, 5 insertions, 17 deletions
diff --git a/devel/rubygem-pygments.rb/Makefile b/devel/rubygem-pygments.rb/Makefile
index 712fdce4f102..e1398bccbac0 100644
--- a/devel/rubygem-pygments.rb/Makefile
+++ b/devel/rubygem-pygments.rb/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pygments.rb
-PORTVERSION= 0.6.3
-PORTREVISION= 1
+PORTVERSION= 1.1.1
CATEGORIES= devel rubygems
MASTER_SITES= RG
@@ -13,8 +12,7 @@ COMMENT= Exposes the pygments syntax highlighter to Ruby
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= rubygem-posix-spawn>=0.3.6:devel/rubygem-posix-spawn \
- rubygem-yajl-ruby>=1.2.0:devel/rubygem-yajl-ruby
+RUN_DEPENDS= rubygem-multi_json>=1.0.0:devel/rubygem-multi_json
NO_ARCH= yes
USE_RUBY= yes
diff --git a/devel/rubygem-pygments.rb/distinfo b/devel/rubygem-pygments.rb/distinfo
index fb2464c55644..f27f6f1f0d68 100644
--- a/devel/rubygem-pygments.rb/distinfo
+++ b/devel/rubygem-pygments.rb/distinfo
@@ -1,2 +1,3 @@
-SHA256 (rubygem/pygments.rb-0.6.3.gem) = d19824fe964cf10388e2852ce3ee888f3e1446c9c2cdc89a55137d8183391198
-SIZE (rubygem/pygments.rb-0.6.3.gem) = 1892352
+TIMESTAMP = 1483154737
+SHA256 (rubygem/pygments.rb-1.1.1.gem) = 139a6d980d2eeff10bc8963fa13eeeb4d4e391c31ae9d1aa701b7087fbbb113c
+SIZE (rubygem/pygments.rb-1.1.1.gem) = 1169920
diff --git a/devel/rubygem-pygments.rb/files/patch-gemspec b/devel/rubygem-pygments.rb/files/patch-gemspec
deleted file mode 100644
index 417542d4d00b..000000000000
--- a/devel/rubygem-pygments.rb/files/patch-gemspec
+++ /dev/null
@@ -1,11 +0,0 @@
---- pygments.rb.gemspec.orig 2016-12-03 11:20:00 UTC
-+++ pygments.rb.gemspec
-@@ -21,7 +21,7 @@ Gem::Specification.new do |s|
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
-- s.add_runtime_dependency(%q<yajl-ruby>.freeze, ["~> 1.2.0"])
-+ s.add_runtime_dependency(%q<yajl-ruby>.freeze, [">= 1.2.0"])
- s.add_runtime_dependency(%q<posix-spawn>.freeze, ["~> 0.3.6"])
- s.add_development_dependency(%q<rake-compiler>.freeze, ["~> 0.7.6"])
- else