aboutsummaryrefslogtreecommitdiff
path: root/devel/subversion-freebsd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/subversion-freebsd/Makefile')
-rw-r--r--devel/subversion-freebsd/Makefile45
1 files changed, 0 insertions, 45 deletions
diff --git a/devel/subversion-freebsd/Makefile b/devel/subversion-freebsd/Makefile
deleted file mode 100644
index e2d610d09861..000000000000
--- a/devel/subversion-freebsd/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# New ports collection makefile for: subversion
-# Date created: 10 September 2001
-# Whom: rooneg@electricjellyfish.net
-#
-# $FreeBSD$
-
-PORTNAME= subversion
-PORTVERSION= r1868
-CATEGORIES= devel
-MASTER_SITES= http://www.tigris.org/files/15/48/
-
-MAINTAINER= rooneg@electricjellyfish.net
-
-LIB_DEPENDS= db4:${PORTSDIR}/databases/db4 \
- neon.19:${PORTSDIR}/www/neon \
- expat.2:${PORTSDIR}/textproc/expat2 \
- apr:${PORTSDIR}/devel/apr-devel
-RUN_DEPENDS= gdiff3:${PORTSDIR}/textproc/diffutils
-BUILD_DEPENDS= gdiff3:${PORTSDIR}/textproc/diffutils
-
-MAN1= svn.1
-
-WRKSRC= ${WRKDIR}/subversion-${PORTVERSION}
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-ssl \
- --with-neon=${LOCALBASE} \
- --with-apr=${LOCALBASE} \
- --with-apr-util=${LOCALBASE}
-
-post-extract:
- # work around libdb4's name.
- @${PERL} -pi -e 's/ldb/ldb4/g' ${WRKSRC}/configure
-
- # axe the neon, apr, and apr-util subdirs to keep svn's build process
- # from using them, since we're providing our own.
- @${RM} -r ${WRKSRC}/neon
- @${RM} -r ${WRKSRC}/apr
- @${RM} -r ${WRKSRC}/apr-util
-
-post-configure:
- # make sure we don't install the swig stuff, even if it was found
- @${PERL} -pi -e 's/install-swig-py-lib//g' ${WRKSRC}/Makefile
- @${PERL} -pi -e 's/swig-py-lib//g' ${WRKSRC}/Makefile
-
-.include <bsd.port.mk>