aboutsummaryrefslogtreecommitdiff
path: root/devel/swig20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/swig20/Makefile')
-rw-r--r--devel/swig20/Makefile55
1 files changed, 0 insertions, 55 deletions
diff --git a/devel/swig20/Makefile b/devel/swig20/Makefile
deleted file mode 100644
index dbe3e27a8fef..000000000000
--- a/devel/swig20/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# New ports collection makefile for: SWIG
-# Date created: 19 April 1996
-# Whom: jkh
-#
-# $FreeBSD$
-#
-
-PORTNAME= swig
-PORTVERSION= 1.3.29
-PORTREVISION= 2
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= alexbl@FreeBSD.org
-COMMENT= Simplified Wrapper and Interface Generator
-
-USE_AUTOTOOLS= autoconf:253:env libtool:15
-
-VER= ${PORTVERSION:R}
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
-
-# Supported languages: guile perl php4 python ruby tcl ocaml pike java csharp
-# allegrocl modula3 chicken
-
-WRKSRC= ${WRKDIR}/${DISTNAME}
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC -DPIC"
-ALL_TARGET= swig
-PLIST_SUB+= VER="${VER}"
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- ${REINPLACE_CMD} -e 's/SKIP_CHICKEN=$$/&"1"/' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|$$RUBY |${RUBY} |' ${WRKSRC}/configure
-
-post-configure:
- ${REINPLACE_CMD} -e 's#null#&|| true#' ${WRKSRC}/Makefile
-
-post-install:
- ${LN} -f ${PREFIX}/bin/swig ${PREFIX}/bin/swig${VER}
- ${MKDIR} ${EXAMPLESDIR}/${PORTVERSION}
- cd ${WRKSRC}/Examples && ${FIND} . -type d \
- -exec ${INSTALL} -d ${EXAMPLESDIR}/${PORTVERSION}/{} \;
- cd ${WRKSRC}/Examples && ${FIND} . -type f \
- -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/${PORTVERSION}/{} \;
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/${PORTVERSION}
- cd ${WRKSRC}/Doc && ${FIND} . -type d \
- -exec ${INSTALL} -d ${DOCSDIR}/${PORTVERSION}/{} \;
- cd ${WRKSRC}/Doc && ${FIND} . -type f \
- -exec ${INSTALL_DATA} {} ${DOCSDIR}/${PORTVERSION}/{} \;
-.endif
-
-.include <bsd.port.post.mk>