aboutsummaryrefslogtreecommitdiff
path: root/dns/dhid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/dhid/Makefile')
-rw-r--r--dns/dhid/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/dns/dhid/Makefile b/dns/dhid/Makefile
deleted file mode 100644
index f2ed00222c1d..000000000000
--- a/dns/dhid/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# New ports collection makefile for: dhid
-# Version required: 3.1
-# Date created: Sat Aug 21 06:13:59 EDT 1999
-# Whom: Oryx Gazella <oryx@ungulate.net>
-#
-# $FreeBSD$
-#
-
-DISTNAME= dhid-3.1
-CATEGORIES= net
-MASTER_SITES= ftp://ftp.dhis.org/pub/dhis/
-
-MAINTAINER= oryx@ungulate.net
-
-MAN8= dhid.8
-
-post-patch:
- @${ECHO} "===> Patching dhid.h"
- ${PERL} -i -p -e "s^__PREFIX__^${PREFIX}^g" ${WRKSRC}/dhid.h
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dhid ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/dhid.8 ${PREFIX}/man/man8
- ${INSTALL} ${COPY} -o root -g wheel -m 600 ${WRKSRC}/dhid.conf ${PREFIX}/etc/dhid.conf.sample
-
-post-install:
- @if [ ! -f ${PREFIX}/etc/rc.d/dhid.sh ]; then \
- ${ECHO} "===> Installing ${PREFIX}/etc/rc.d/dhid.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/dhid.sh; \
- ${ECHO} "[ -x \"${PREFIX}/sbin/dhid\" -a -f \"${PREFIX}/etc/dhid.conf\" ] && ${PREFIX}/sbin/dhid > /dev/null && echo -n ' dhid'" >> ${PREFIX}/etc/rc.d/dhid.sh; \
- chmod 751 ${PREFIX}/etc/rc.d/dhid.sh; \
- fi;
- @${ECHO} "--------------------------------------------------------------------------"
- @${ECHO} "Before dhid can run, you will need to register with a DHIS provider."
- @${ECHO} "See http://www.dhis.org/dhis/services/ for a list of providers."
- @${ECHO} "Enter the DHIS account information into the ${PREFIX}/etc/dhid.conf file."
- @${ECHO} "--------------------------------------------------------------------------"
-
-.include <bsd.port.mk>