aboutsummaryrefslogtreecommitdiff
path: root/dns/libidn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/libidn/Makefile')
-rw-r--r--dns/libidn/Makefile55
1 files changed, 0 insertions, 55 deletions
diff --git a/dns/libidn/Makefile b/dns/libidn/Makefile
deleted file mode 100644
index 18a2575a31eb..000000000000
--- a/dns/libidn/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# New ports collection makefile for: libidn
-# Date created: 19.06.2003
-# Whom: Kirill Ponomarew <ponomarew@oberon.net>
-#
-# $FreeBSD$
-#
-
-PORTNAME= libidn
-PORTVERSION= 0.4.2
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU_ALPHA} \
- http://josefsson.org/libidn/releases/
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= krion@FreeBSD.org
-COMMENT= Internationalized Domain Names command line tool
-
-BUILD_DEPENDS= gengetopt:${PORTSDIR}/devel/gengetopt
-
-USE_GETOPT_LONG= yes
-USE_GNOME= gnomehack
-USE_ICONV= yes
-USE_LIBTOOL_VER= 13
-USE_PERL5_BUILD= yes
-USE_REINPLACE= yes
-INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-INFO= libidn
-
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|@image{components}||g' \
- ${WRKSRC}/doc/libidn.texi
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in README FAQ
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
-
-.include "Makefile.man"
-.include <bsd.port.mk>