aboutsummaryrefslogtreecommitdiff
path: root/dns/yandex-ddns/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/yandex-ddns/Makefile')
-rw-r--r--dns/yandex-ddns/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/dns/yandex-ddns/Makefile b/dns/yandex-ddns/Makefile
new file mode 100644
index 000000000000..3534ab3a8cf7
--- /dev/null
+++ b/dns/yandex-ddns/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= yandex-ddns
+DISTVERSION= g20200613
+CATEGORIES= dns
+
+MAINTAINER= rigoletto@FreeBSD.org
+COMMENT= Use Yandex DNS as a dynamic DNS provider
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= thekvs
+GH_TAGNAME= 1fd0d00
+
+PLIST_FILES= bin/yandex-ddns\
+ ${EXAMPLESDIR}/yandex-ddns.example.toml
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/yandex-ddns.example.toml \
+ ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>