aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/gedit/Makefile')
-rw-r--r--editors/gedit/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index d9943e75ba41..16252e102400 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gedit
-PORTVERSION= 3.16.4
+PORTVERSION= 3.18.3
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -23,7 +23,7 @@ RUN_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake libtool \
+USES= desktop-file-utils gettext gmake gnome libtool \
pathfix pkgconfig python:3 tar:xz
USE_GNOME= gtksourceview3 intlhack introspection:build \
libxml2 py3gobject3
@@ -34,6 +34,7 @@ CONFIGURE_ARGS= --disable-updater \
CPPFLAGS+= -I${LOCALBASE}/include -Wno-error=format-nonliteral
CFLAGS+= -I${LOCALBASE}/include -Wno-error=format-nonliteral
LDFLAGS+= -L${LOCALBASE}/lib
+USE_LDCONFIG= yes
PLIST_SUB= VERSION="3.14"
INSTALL_TARGET= install-strip
@@ -48,4 +49,8 @@ GLIB_SCHEMAS= org.gnome.gedit.enums.xml \
PLIST_SUB+= PYVER=${PYTHON_VER:S/.//}
+post-patch:
+ @${REINPLACE_CMD} -e 's|=python|=${PYTHON_CMD}|g' \
+ ${WRKSRC}/py-compile
+
.include <bsd.port.mk>