aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-vcltesttool/files/Makefile.knobs
diff options
context:
space:
mode:
Diffstat (limited to 'editors/openoffice.org-vcltesttool/files/Makefile.knobs')
-rw-r--r--editors/openoffice.org-vcltesttool/files/Makefile.knobs164
1 files changed, 0 insertions, 164 deletions
diff --git a/editors/openoffice.org-vcltesttool/files/Makefile.knobs b/editors/openoffice.org-vcltesttool/files/Makefile.knobs
deleted file mode 100644
index a4d76e99c1aa..000000000000
--- a/editors/openoffice.org-vcltesttool/files/Makefile.knobs
+++ /dev/null
@@ -1,164 +0,0 @@
-# Makefile for knobs
-# Whom: Maho Nakata <maho@FreeBSD.org>
-# $FreeBSD$
-
-CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home="${LOCALBASE}/share/java/apache-ant"
-
-.if defined(WITH_VBA)
-CONFIGURE_ARGS+= --enable-vba --with-vba-package-format="builtin"
-.endif
-
-.if defined(WITH_KDE)
-CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
-.endif
-
-.if defined(WITH_CUPS)
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
-CONFIGURE_ARGS+= --enable-cups=yes
-.else
-CONFIGURE_ARGS+= --enable-cups=no
-.endif
-
-.if defined(WITHOUT_MOZILLA)
-CONFIGURE_ARGS+= --disable-mozilla
-.else
-CONFIGURE_ARGS+= --enable-build-mozilla
-.endif
-
-.if defined(WITHOUT_GNOMEVFS)
-CONFIGURE_ARGS+= --disable-gnome-vfs
-.else
-USE_GNOME+= gnomevfs2
-.endif
-
-.if defined(WITH_EVOLUTION2)
-CONFIGURE_ARGS+= --enable-evolution2=yes
-.else
-USE_GNOME+= glib20
-.endif
-
-.if defined(WITH_SYSTEM_FREETYPE)
-LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
-CONFIGURE_ARGS+= --with-system-freetype=yes
-.else
-CONFIGURE_ARGS+= --with-system-freetype=no
-.endif
-
-.if defined(ALL_LOCALIZED_LANGS)
-CONFIGURE_ARGS+= --with-lang=ALL
-.else
-CONFIGURE_ARGS+= --with-lang=${LOCALIZED_LANG}
-.endif
-
-.if defined(WITH_DEBUG)
-.if ${WITH_DEBUG} == 2
-CONFIGURE_ARGS+= --enable-debug
-.else
-CONFIGURE_ARGS+= --enable-symbols
-.endif
-.endif
-
-pre-fetch:
-.if (${OSVERSION} < 503001 && ${OSVERSION} >= 500000) || (${OSVERSION} < 492000)
- @${ECHO}
- @${ECHO} "WARNING"
- @${ECHO} "Your rtld seems to be old."
- @${ECHO} "Please remake your rtld by:"
- @${ECHO} "[1] if you use 4-series:"
- @${ECHO} "# fetch http://people.freebsd.org/~maho/ooo/patch-rtld.c-releng4"
- @${ECHO} "# cd /usr/src/libexec/rtld-elf ; patch < patch-rtld.c-releng4"
- @${ECHO} "# make ; make depend ; make install"
- @${ECHO} "[2] if you use 5-series:"
- @${ECHO} "# fetch http://people.freebsd.org/~maho/ooo/patch-rtld.c-releng5"
- @${ECHO} "# cd /usr/src/libexec/rtld-elf ; patch < patch-rtld.c-releng5"
- @${ECHO} "# make ; make depend ; make install"
- @${ECHO} "AT YOUR OWN RISK!"
-.endif
- @${ECHO} "OPTIONS:"
-.if !defined(WITH_DEBUG)
- @${ECHO}
- @${ECHO} "You can compile OOo with debug symbols with WITH_DEBUG=1"
- @${ECHO}
- @${ECHO} "If you set WITH_DEBUG=2, you add internal"
- @${ECHO} "OOo debug support."
-.endif
-.if !defined(WITHOUT_MOZILLA)
- @${ECHO}
- @${ECHO} "You can compile OOo without Mozilla connectivity with"
- @${ECHO} "make -DWITHOUT_MOZILLA"
-.endif
-.if !defined(WITHOUT_GNOMEVFS)
- @${ECHO}
- @${ECHO} "You can compile OOo without gnome VFS support with"
- @${ECHO} "make -DWITHOUT_GNOMEVFS"
-.endif
-.if !defined(WITH_VBA)
- @${ECHO}
- @${ECHO} "You can compile OOo with VBA support with"
- @${ECHO} "make -DWITH_VBA"
-.endif
-.if !defined(WITH_SYSTEM_FREETYPE)
- @${ECHO}
- @${ECHO} "You can compile OOo with freetype2 from ports with"
- @${ECHO} "make -DWITH_SYSTEM_FREETYPE"
-.if !defined(WITH_TTF_BYTECODE_ENABLED)
- @${ECHO}
- @${ECHO} "You may get better quality of glyphs"
- @${ECHO} "at small bitmap sizes if you have"
- @${ECHO} "licensed the Apple patents"
- @${ECHO} "US05155805 US05159668 and US05325479, with"
- @${ECHO} "make -DWITH_TTF_BYTECODE_ENABLED"
- @${ECHO} "See http://www.freetype.org/patents.html for details"
-.endif
-.endif
-.if !defined(LOCALIZED_LANG)
- @${ECHO}
- @${ECHO} "You can select the language for OOo by making it with:"
- @${ECHO} "make LOCALIZED_LANG=xx"
- @${ECHO} "while xx can be one of the following"
- @${ECHO} "af ar as-IN be-BY bg br bn bn-BD bn-IN bs ca cs cy da"
- @${ECHO} "de el en-GB en-US en-ZA eo es et eu fa fi fr ga gl"
- @${ECHO} "gu-IN he hi-IN hr hu it ja km kn-IN ko ku lo lt lv mk"
- @${ECHO} "ms ml-IN mr-IN ne nb nl nn nr ns or-IN pa-IN pl pt"
- @${ECHO} "pt-BR ru rw sk sl sh-YU sr-CS ss st sv sw sw-TZ sx"
- @${ECHO} "te-IN ti-ER ta-IN th tn tr ts tg ur-IN uk ve vi xh"
- @${ECHO} "zh-CN zh-TW zu"
- @${ECHO} "Default: en-US"
-.endif
-.if !defined(WITH_CUPS)
- @${ECHO}
- @${ECHO} "You can compile OOo with CUPS support with"
- @${ECHO} "make -DWITH_CUPS"
-.endif
-.if !defined(WITH_KDE)
- @${ECHO}
- @${ECHO} "You can compile OOo to use Qt/KDE vclplug with"
- @${ECHO} "make -DWITH_KDE"
-.endif
-.if !defined(WITH_GPC)
- @${ECHO}
- @${ECHO} "You can compile OOo with gpc instead of libart by"
- @${ECHO} "make -DWITH_GPC"
-.endif
-.if !defined(WITH_EVOLUTION2)
- @${ECHO}
- @${ECHO} "You can compile OOo with evolution2 support by"
- @${ECHO} "make -DWITH_EVOLUTION2"
-.endif
-.if ${LOCALIZED_LANG} != "all"
- @${ECHO}
- @${ECHO} "You can compile OOo with full localized language support by"
- @${ECHO} "make LOCALIZED_LANG=all"
-.endif
- @${ECHO}
- @${ECHO} "NOTICE:"
- @${ECHO}
- @${ECHO} "To build OOo, you should have a lot"
-.if defined(WITH_DEBUG)
- @${ECHO} "of free diskspace (~ 18GB) and memory (~ 2GB)."
-.elif ${LOCALIZED_LANG} == "all"
- @${ECHO} "of free diskspace (~ 35GB) and memory (~ 2GB)."
-.else
- @${ECHO} "of free diskspace (~ 11GB) and memory (~ 2GB)."
-.endif
- @${ECHO} "If you want SDK and/or solver, please type make sdk and/or make solver"