aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/xemacs/Makefile')
-rw-r--r--editors/xemacs/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/editors/xemacs/Makefile b/editors/xemacs/Makefile
index b4eff16e82da..ad1350cbe8a2 100644
--- a/editors/xemacs/Makefile
+++ b/editors/xemacs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xemacs
PORTVERSION= ${XEMACS_VER}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= xemacs-${XEMACS_REL}
@@ -91,11 +91,12 @@ CONFIGURE_ARGS+= --without-postgresql
RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/etc/enriched.doc:${PORTSDIR}/editors/xemacs-packages
.endif
.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+= --with-png --with-jpeg --with-tiff
-USE_XORG= xpm x11
+USE_XORG= xpm x11 xbitmaps xaw
+CFLAGS+= -I${LOCALBASE}/include/libpng15
.if !defined(WITHOUT_MOTIF) && !defined(MOTIF_STATIC)
USE_MOTIF= yes
WITH_SCROLLBARS= --with-scrollbars=motif