aboutsummaryrefslogtreecommitdiff
path: root/editors/xmlcopyeditor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/xmlcopyeditor/Makefile')
-rw-r--r--editors/xmlcopyeditor/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index 8d89935e9d61..6fd35904fa79 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -1,35 +1,34 @@
PORTNAME= xmlcopyeditor
-PORTVERSION= 1.3.0.0
-PORTREVISION= 3
+DISTVERSION= 1.3.1.0
+PORTREVISION= 2
CATEGORIES= editors
-MASTER_SITES= SF/xml-copy-editor/${PORTNAME}-linux/${PORTVERSION}
+MASTER_SITES= SF/xml-copy-editor/${PORTNAME}-linux/${DISTVERSION}
-MAINTAINER= jjuanino@gmail.com
+MAINTAINER= eduardo@FreeBSD.org
COMMENT= Fast validating XML editor
+WWW= http://xml-copy-editor.sourceforge.net/
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libaspell.so:textproc/aspell \
- libenchant.so:textproc/enchant \
+ libenchant-2.so:textproc/enchant2 \
libexpat.so:textproc/expat2 \
libharfbuzz.so:print/harfbuzz \
- libpcre.so:devel/pcre \
- libxerces-c.so.3:textproc/xerces-c3 \
+ libpcre2-8.so:devel/pcre2 \
+ libxerces-c.so:textproc/xerces-c3 \
libxml2.so:textproc/libxml2 \
libxslt.so:textproc/libxslt
USES= autoreconf compiler:c++11-lang desktop-file-utils dos2unix \
- gmake gettext-tools gnome iconv libtool pkgconfig
+ gettext-tools gmake gnome iconv libtool localbase pkgconfig
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 intltool pango
-USE_WX= 3.0+
+USE_WX= 3.0 # fails to build with 3.2
WX_COMPS= wx
WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-nls # NLS does not work properly
-CPPFLAGS+= -I${LOCALBASE}/include
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
.include <bsd.port.mk>