aboutsummaryrefslogtreecommitdiff
path: root/emulators/ppsspp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/ppsspp/Makefile')
-rw-r--r--emulators/ppsspp/Makefile28
1 files changed, 7 insertions, 21 deletions
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index 2279aa4713a2..5b1012532c5a 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -1,28 +1,13 @@
PORTNAME= ppsspp
DISTVERSIONPREFIX= v
-DISTVERSION?= 1.11.3
-PORTREVISION?= 2
+DISTVERSION?= 1.12
+PORTREVISION?= 0
CATEGORIES= emulators
# XXX Get from Debian once #697821 lands
MASTER_SITES= https://bazaar.launchpad.net/~sergio-br2/${PORTNAME}/debian-sdl/download/5/${PORTNAME}.1-20140802045408-dd26dik367ztj5xg-8/:manpage
DISTFILES= ${PORTNAME}.1:manpage
EXTRACT_ONLY= ${DISTFILES:N*\:manpage:C/:.*//}
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= 2362d71d70ad.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14176
-PATCHFILES+= 26eca0ba3dc0.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14176
-PATCHFILES+= 6656c8a533ee.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14176
-PATCHFILES+= 2b2dae60d316.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14176
-PATCHFILES+= b19e39efb0ca.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14176
-PATCHFILES+= e5849d109dc2.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14176
-PATCHFILES+= e3be3d5f7b0e.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14176
-PATCHFILES+= 0ab6f1d0804c.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14176
-PATCHFILES+= 54dd4e4c0cd7.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14176
-PATCHFILES+= ed2610cf1a89.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14188
-PATCHFILES+= d8e3bae2da1a.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14188
-PATCHFILES+= 9d031caa9d8b.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14188
-PATCHFILES+= d6dc6e9d642f.patch:-p1 # https://github.com/hrydgard/ppsspp/pull/14199
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= PSP emulator in C++ with dynarec JIT for x86, ARM, MIPS
@@ -40,10 +25,11 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils
USE_GITHUB= yes
GH_ACCOUNT= hrydgard
-GH_TUPLE?= hrydgard:glslang:8.13.3559-76-gd0850f87:glslang/ext/glslang \
- hrydgard:miniupnp:miniupnpd_2_1-354-g7e229dd:miniupnp/ext/miniupnp \
- hrydgard:${PORTNAME}-lang:6bd5b4b:lang/assets/lang \
- KhronosGroup:SPIRV-Cross:2019-05-20-60-ga1f7c8dc:SPIRV/ext/SPIRV-Cross \
+GH_TUPLE?= hrydgard:glslang:8.13.3743-339-gdc11adde:glslang/ext/glslang \
+ hrydgard:miniupnp:miniupnpd_2_1-502-g3a87be3:miniupnp/ext/miniupnp \
+ facebook:zstd:v1.5.0:zstd/ext/zstd \
+ unknownbrackets:ppsspp-debugger:36ad6b1:debugger/assets/debugger \
+ KhronosGroup:SPIRV-Cross:2021-01-15:SPIRV/ext/SPIRV-Cross \
Kingcom:armips:v0.10.0-28-g7885552:armips/ext/armips
CONFLICTS_INSTALL= ${PORTNAME}-*