aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/virtualbox-ose/Makefile')
-rw-r--r--emulators/virtualbox-ose/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 0b59cc614327..b2e4e297be04 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -234,18 +234,18 @@ PLIST_SUB+= PYTHON_PYCDIR=/ \
CONFIGURE_ARGS+= --with-openssl-dir="${OPENSSLBASE}"
.endif
-#pre-everything::
-#.if ${ARCH} == "amd64"
-#.if ${_ELF32} != yes
-# @${ECHO_MSG} 'Requires 32-bit runtime support in kernel.'
-# @${ECHO_MSG} 'Rebuild kernel with "options COMPAT_FREEBSD32" and reboot.'
-# @${FALSE}
-#.elif !exists(/usr/lib32/libc.so)
-# @${ECHO_MSG} 'Requires 32-bit libraries installed under /usr/lib32.'
-# @${ECHO_MSG} 'Do: cd /usr/src; make build32 install32; service ldconfig restart'
-# @${FALSE}
-#.endif
-#.endif
+pre-everything::
+.if ${ARCH} == "amd64"
+.if ${_ELF32} != yes
+ @${ECHO_MSG} 'Requires 32-bit runtime support in kernel.'
+ @${ECHO_MSG} 'Rebuild kernel with "options COMPAT_FREEBSD32" and reboot.'
+ @${FALSE}
+.elif !exists(/usr/lib32/libc.so)
+ @${ECHO_MSG} 'Requires 32-bit libraries installed under /usr/lib32.'
+ @${ECHO_MSG} 'Do: cd /usr/src; make build32 install32; service ldconfig restart'
+ @${FALSE}
+.endif
+.endif
post-patch:
@${ECHO_CMD} 'VBOX_PATH_APP_PRIVATE_ARCH = ${VBOX_DIR}' > \