aboutsummaryrefslogtreecommitdiff
path: root/finance/chiapos/files
diff options
context:
space:
mode:
Diffstat (limited to 'finance/chiapos/files')
-rw-r--r--finance/chiapos/files/Hellman-Makefile14
-rw-r--r--finance/chiapos/files/patch-CMakeLists.txt89
-rw-r--r--finance/chiapos/files/patch-setup.py30
3 files changed, 133 insertions, 0 deletions
diff --git a/finance/chiapos/files/Hellman-Makefile b/finance/chiapos/files/Hellman-Makefile
new file mode 100644
index 000000000000..e44416fad87f
--- /dev/null
+++ b/finance/chiapos/files/Hellman-Makefile
@@ -0,0 +1,14 @@
+all: HellmanAttacks
+
+OBJ = aes.o bits.o calculate_bucket.o cxxopts.o encoding.o hellman.o picosha2.o plotter_disk.o pos_constants.o prover_disk.o sort_on_disk.o util.o verifier.o
+
+.SUFFIXES:.hpp .o
+
+.hpp.o:
+ $(CC) -c $(CXXFLAGS) $(DFLAGS) $(INCLUDES) $< -o $@
+
+HellmanAttacks: ${OBJ}
+ ${CC} -o HellmanAttacks ${OBJ}
+
+clean:
+ rm -f HellmanAttacks ${OBJ}
diff --git a/finance/chiapos/files/patch-CMakeLists.txt b/finance/chiapos/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a81293d75db6
--- /dev/null
+++ b/finance/chiapos/files/patch-CMakeLists.txt
@@ -0,0 +1,89 @@
+--- CMakeLists.txt.orig 2021-05-28 02:40:44 UTC
++++ CMakeLists.txt
+@@ -14,29 +14,7 @@ endif()
+ project(chiapos C CXX ASM)
+
+ # CMake 3.14+
+-include(FetchContent)
+
+-FetchContent_Declare(
+- pybind11-src
+- GIT_REPOSITORY https://github.com/pybind/pybind11.git
+- GIT_TAG v2.6.2
+-)
+-FetchContent_MakeAvailable(pybind11-src)
+-
+-FetchContent_Declare(
+- cxxopts
+- GIT_REPOSITORY https://github.com/jarro2783/cxxopts.git
+- GIT_TAG v2.2.1
+-)
+-FetchContent_MakeAvailable(cxxopts)
+-
+-FetchContent_Declare(
+- gulrak
+- GIT_REPOSITORY https://github.com/gulrak/filesystem.git
+- GIT_TAG v1.5.6
+-)
+-FetchContent_MakeAvailable(gulrak)
+-
+ set(FSE_LIB ${CMAKE_CURRENT_SOURCE_DIR}/lib/FiniteStateEntropy/lib)
+ set(FSE_FILES
+ ${FSE_LIB}/fse_compress.c
+@@ -48,8 +26,8 @@ set(FSE_FILES
+ include_directories(
+ ${INCLUDE_DIRECTORIES}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../lib/include
+- ${cxxopts_SOURCE_DIR}/include
+- ${gulrak_SOURCE_DIR}/include/ghc
++ ${CMAKE_CURRENT_SOURCE_DIR}/src-ext/cxxopts/include
++ ${CMAKE_CURRENT_SOURCE_DIR}/src-ext/gulrak/include/ghc
+ ${CMAKE_CURRENT_SOURCE_DIR}/../lib/FiniteStateEntropy/lib
+ ${CMAKE_CURRENT_SOURCE_DIR}/src
+ ${CMAKE_CURRENT_SOURCE_DIR}/test
+@@ -130,8 +108,6 @@ set(BLAKE3_SRC
+ )
+ ENDIF()
+
+-pybind11_add_module(chiapos ${CMAKE_CURRENT_SOURCE_DIR}/python-bindings/chiapos.cpp src/chacha8.c ${BLAKE3_SRC})
+-
+ add_executable(ProofOfSpace
+ src/cli.cpp
+ src/chacha8.c
+@@ -145,33 +121,30 @@ add_executable(RunTests
+ ${BLAKE3_SRC}
+ )
+
++install(TARGETS ProofOfSpace DESTINATION bin)
++install(TARGETS RunTests DESTINATION bin)
++
+ find_package(Threads REQUIRED)
+
+ add_library(uint128 STATIC uint128_t/uint128_t.cpp)
+ target_include_directories(uint128 PUBLIC uint128_t)
+
+ target_compile_features(fse PUBLIC cxx_std_17)
+-target_compile_features(chiapos PUBLIC cxx_std_17)
+ target_compile_features(RunTests PUBLIC cxx_std_17)
+
+ if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+- target_link_libraries(chiapos PRIVATE fse Threads::Threads)
+ target_link_libraries(ProofOfSpace fse Threads::Threads)
+ target_link_libraries(RunTests fse Threads::Threads)
+ elseif (${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD")
+- target_link_libraries(chiapos PRIVATE fse Threads::Threads)
+ target_link_libraries(ProofOfSpace fse Threads::Threads)
+ target_link_libraries(RunTests fse Threads::Threads)
+ elseif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+- target_link_libraries(chiapos PRIVATE fse Threads::Threads)
+ target_link_libraries(ProofOfSpace fse Threads::Threads)
+ target_link_libraries(RunTests fse Threads::Threads)
+ elseif (MSVC)
+- target_link_libraries(chiapos PRIVATE fse Threads::Threads uint128)
+ target_link_libraries(ProofOfSpace fse Threads::Threads uint128)
+ target_link_libraries(RunTests fse Threads::Threads uint128)
+ else()
+- target_link_libraries(chiapos PRIVATE fse stdc++fs Threads::Threads)
+ target_link_libraries(ProofOfSpace fse stdc++fs Threads::Threads)
+ target_link_libraries(RunTests fse stdc++fs Threads::Threads)
+ endif()
diff --git a/finance/chiapos/files/patch-setup.py b/finance/chiapos/files/patch-setup.py
new file mode 100644
index 000000000000..89dd1339a6b5
--- /dev/null
+++ b/finance/chiapos/files/patch-setup.py
@@ -0,0 +1,30 @@
+--- setup.py.orig 2021-05-28 02:40:44 UTC
++++ setup.py
+@@ -107,9 +100,6 @@ ext_modules = [
+ "src/chacha8.c",
+ ],
+ include_dirs=[
+- # Path to pybind11 headers
+- get_pybind_include(),
+- get_pybind_include(user=True),
+ "src",
+ "uint128_t",
+ ".",
+@@ -202,6 +192,7 @@ if platform.system() == "Windows":
+ else:
+ setup(
+ name="chiapos",
++ version="1.0.3",
+ author="Mariano Sorgente",
+ author_email="mariano@chia.net",
+ description="Chia proof of space plotting, proving, and verifying (wraps C++)",
+@@ -209,8 +200,7 @@ else:
+ python_requires=">=3.7",
+ long_description=open("README.md").read(),
+ long_description_content_type="text/markdown",
+- url="https://github.com/Chia-Network/chiavdf",
+- ext_modules=[CMakeExtension("chiapos", ".")],
++ url="https://github.com/Chia-Network/chiapos",
+ cmdclass=dict(build_ext=CMakeBuild),
+ zip_safe=False,
+ )