aboutsummaryrefslogtreecommitdiff
path: root/finance/kmymoney-kde4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/kmymoney-kde4/Makefile')
-rw-r--r--finance/kmymoney-kde4/Makefile56
1 files changed, 0 insertions, 56 deletions
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
deleted file mode 100644
index c32f711d08fb..000000000000
--- a/finance/kmymoney-kde4/Makefile
+++ /dev/null
@@ -1,56 +0,0 @@
-# New ports collection makefile for: KMyMoney
-# Date created: 21 June 2004
-# Whom: Alexander Novitsky
-#
-# $FreeBSD$
-#
-
-PORTNAME= kmymoney2
-PORTVERSION= 0.8.7
-PORTREVISION= 2
-CATEGORIES= finance
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= alecn2002@yandex.ru
-COMMENT= KDE-based personal finance assistant
-
-LIB_DEPENDS= osp.5:${PORTSDIR}/textproc/opensp
-BUILD_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
-
-# Currently no possibility to enable OFX; requires additional work
-.undef WITH_OFX
-WITHOUT_OFX= yes
-
-.if defined(WITH_OFX)
-LIB_DEPENDS+= ofx.3:${PORTSDIR}/finance/libofx
-CONFIGURE_ARGS= --enable-ofxplugin
-OFXPLUGIN=
-.else
-CONFIGURE_ARGS= --enable-ofxplugin=no
-OFXPLUGIN= "@comment "
-.endif
-
-PLIST_SUB+= OFXPLUGIN=${OFXPLUGIN}
-
-USE_KDELIBS_VER= 3
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:15
-USE_PERL5= yes
-USE_BZIP2= yes
-USE_LDCONFIG= yes
-USE_GETTEXT= yes
-
-INSTALLS_ICONS= yes
-
-MAN1= kmymoney2.1
-MANCOMPRESSED= yes
-
-DATADIR= ${PREFIX}/share/apps/${PORTNAME}
-DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
-
-post-patch:
- ${REINPLACE_CMD} -E -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/configure
-
-.include <bsd.port.mk>