aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp')
-rw-r--r--ftp/tnftpd/Makefile1
-rw-r--r--ftp/tnftpd/files/patch-configure.ac20
-rw-r--r--ftp/tnftpd/files/patch-libnetbsd-Makefile.am7
3 files changed, 15 insertions, 13 deletions
diff --git a/ftp/tnftpd/Makefile b/ftp/tnftpd/Makefile
index 97a5a8bf2612..0e3057a6f691 100644
--- a/ftp/tnftpd/Makefile
+++ b/ftp/tnftpd/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= cejkar@fit.vutbr.cz
COMMENT= Enhanced ftp server from NetBSD
USE_AUTOTOOLS= aclocal automake libtool
+AUTOMAKE_ARGS= --add-missing
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
.include <bsd.port.pre.mk>
diff --git a/ftp/tnftpd/files/patch-configure.ac b/ftp/tnftpd/files/patch-configure.ac
index 9383d31a434b..a8b66edcbf37 100644
--- a/ftp/tnftpd/files/patch-configure.ac
+++ b/ftp/tnftpd/files/patch-configure.ac
@@ -1,14 +1,8 @@
-Feature silent-rules needs atleast autoconf 1.11, however we still have
-at most autoconf 1.10 in ports tree (2010/09/10).
-
---- configure.ac.orig 2010-03-24 13:31:39.000000000 +0100
-+++ configure.ac 2010-03-24 13:31:39.000000000 +0200
-@@ -18,7 +18,7 @@
- AC_CONFIG_HEADERS([tnftpd_config.h])
- AC_CONFIG_LIBOBJ_DIR([libnetbsd])
-
--AM_INIT_AUTOMAKE([-Wall -Werror foreign nostdinc silent-rules])
-+AM_INIT_AUTOMAKE([-Wall -Werror foreign nostdinc])
- AM_MAINTAINER_MODE
-
+--- configure.ac.orig 2010-03-24 05:31:39.000000000 -0700
++++ configure.ac 2012-05-03 15:55:32.000000000 -0700
+@@ -87,3 +87,4 @@
#
+-AC_PROG_CC
++AM_PROG_CC_C_O
++AM_PROG_AR
+ AC_PROG_AWK
diff --git a/ftp/tnftpd/files/patch-libnetbsd-Makefile.am b/ftp/tnftpd/files/patch-libnetbsd-Makefile.am
new file mode 100644
index 000000000000..564d9dc47fd1
--- /dev/null
+++ b/ftp/tnftpd/files/patch-libnetbsd-Makefile.am
@@ -0,0 +1,7 @@
+--- libnetbsd/Makefile.am.orig 2010-01-03 21:46:29.000000000 -0800
++++ libnetbsd/Makefile.am 2012-05-03 15:58:12.000000000 -0700
+@@ -6,3 +6,3 @@
+
+-CPPFLAGS = \
++AM_CPPFLAGS = \
+ -I$(srcdir) \