aboutsummaryrefslogtreecommitdiff
path: root/games/egl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/egl/Makefile')
-rw-r--r--games/egl/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/egl/Makefile b/games/egl/Makefile
index 48728f379e2f..6a4b0d0f1520 100644
--- a/games/egl/Makefile
+++ b/games/egl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= egl
PORTVERSION= 0.3.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= http://egl.quakedev.com/files/:src \
ftp://ftp.alepulver.com.ar/distfiles/:data
@@ -41,8 +41,10 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.if defined(WITH_CLIENT)
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
USE_GL= yes
+CFLAGS+= -I${LOCALBASE}/include/libpng15
+MAKE_ENV*= CFLAGS="${CFLAGS}"
PLIST_SUB+= CLIENT=""
EGL_BIN+= egl
.else