aboutsummaryrefslogtreecommitdiff
path: root/games/liblcf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/liblcf/Makefile')
-rw-r--r--games/liblcf/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/games/liblcf/Makefile b/games/liblcf/Makefile
new file mode 100644
index 000000000000..853aad2d6774
--- /dev/null
+++ b/games/liblcf/Makefile
@@ -0,0 +1,36 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= liblcf
+PORTVERSION= 0.3.2
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Library to handle RPG Maker 2000/2003 and EasyRPG projects
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libicui18n.so:devel/icu \
+ libexpat.so:textproc/expat2
+
+USE_GITHUB= yes
+GH_ACCOUNT= EasyRPG
+
+USES= autoreconf libtool pathfix pkgconfig
+PATHFIX_MAKEFILEIN= Makefile.am
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+PORTDOCS= AUTHORS README
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>