aboutsummaryrefslogtreecommitdiff
path: root/games/pentobi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/pentobi/Makefile')
-rw-r--r--games/pentobi/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/games/pentobi/Makefile b/games/pentobi/Makefile
new file mode 100644
index 000000000000..255223266456
--- /dev/null
+++ b/games/pentobi/Makefile
@@ -0,0 +1,27 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pentobi
+PORTVERSION= 13.1
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Computer opponent for the board game Blokus
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake desktop-file-utils shared-mime-info tar:xz
+USE_QT5= core gui widgets svg concurrent \
+ qmake_build buildtools_build linguisttools_build
+
+PORTDOCS= NEWS
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>