aboutsummaryrefslogtreecommitdiff
path: root/games/q2p/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/q2p/Makefile')
-rw-r--r--games/q2p/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/q2p/Makefile b/games/q2p/Makefile
index b334dfd3fcf1..3297aca0691f 100644
--- a/games/q2p/Makefile
+++ b/games/q2p/Makefile
@@ -7,7 +7,7 @@
PORTNAME= q2p
PORTVERSION= 0.2.20061231
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= http://qudos.quakedev.com/linux/quake2/engines/Q2P/
DISTNAME= Q2P-0.2-2006-12-31
@@ -40,7 +40,7 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.if !defined(WITHOUT_GLX) || !defined(WITHOUT_SDLGL)
USE_GL= glu
-LIB_DEPENDS+= jpeg.10:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
.endif
@@ -109,6 +109,11 @@ Q2SND+= sdl
PLIST_SUB+= SDL="@comment "
.endif
+post-patch:
+# Resolve name collision with jpeg-8
+ ${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
+ ${WRKSRC}/ref_gl/gl_image.c
+
do-install:
.for bin in ${Q2BIN}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/${bin} ${PREFIX}/bin