aboutsummaryrefslogtreecommitdiff
path: root/games/xracer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xracer/Makefile')
-rw-r--r--games/xracer/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/xracer/Makefile b/games/xracer/Makefile
index 2e8d43023789..dc989095b31d 100644
--- a/games/xracer/Makefile
+++ b/games/xracer/Makefile
@@ -19,10 +19,13 @@ USE_XLIB= yes
USE_MESA= yes
USE_GMAKE= yes
USE_AUTOMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-esd
+post-patch:
+ @${TOUCH} ${WRKSRC}/stamp-h.in
+
post-install:
@${ECHO} "===> Installing Tracks and Sound"
@${MKDIR} ${PREFIX}/share/xracer