aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/xlines/Makefile4
-rw-r--r--games/xlines/files/patch-aa24
2 files changed, 22 insertions, 6 deletions
diff --git a/games/xlines/Makefile b/games/xlines/Makefile
index 320dd3b7b4f2..e2de4663b05f 100644
--- a/games/xlines/Makefile
+++ b/games/xlines/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 February 1998
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.5 1998/08/07 23:56:22 asami Exp $
+# $Id: Makefile,v 1.6 1998/08/12 06:29:28 asami Exp $
#
DISTNAME= xlines
@@ -24,6 +24,8 @@ do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/xlines ${PREFIX}/bin
@ ${MKDIR} ${PREFIX}/share/xlines
@ ${INSTALL_DATA} ${WRKSRC}/trolltech.gif ${PREFIX}/share/xlines
+
+post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/xlines
@ ${INSTALL_DATA} ${WRKSRC}/readme.lines ${PREFIX}/share/doc/xlines
diff --git a/games/xlines/files/patch-aa b/games/xlines/files/patch-aa
index b2af4347e014..e2f233bb005f 100644
--- a/games/xlines/files/patch-aa
+++ b/games/xlines/files/patch-aa
@@ -1,16 +1,30 @@
---- Makefile Mon Apr 27 21:47:35 1998
-+++ /home/andy/tmp/wrk/Makefile Mon Jul 6 11:56:02 1998
-@@ -1,8 +1,8 @@
+--- Makefile Tue Apr 28 01:47:35 1998
++++ /home/andy/tmp/wrk/Makefile Sat May 1 13:01:53 1999
+@@ -1,8 +1,7 @@
-INCDIR=/usr/local/qt/include
-CFLAGS=-O2 -I/usr/X11/include -DSHOW_NEXT_COLORS
-LFLAGS=-L/usr/local/qt/lib -lqt -L/usr/X11/lib -lX11
-CC=gcc
-MOC=/usr/local/qt/bin/moc
+INCDIR=${X11BASE}/include/X11/qt
-+CFLAGS+=-I${X11BASE}/include -DSHOW_NEXT_COLORS
++CXXFLAGS+=-I${X11BASE}/include -DSHOW_NEXT_COLORS
+LFLAGS=-L${X11BASE}/lib -lqt -lX11
-+#CC=gcc
+MOC=${X11BASE}/bin/moc
SRC=lines.cpp lines.moc
OBJECTS=lines.o
+@@ -14,12 +13,12 @@
+ .SUFFIXES: .cpp
+
+ .cpp.o:
+- $(CC) -c $(CFLAGS) -I$(INCDIR) $<
++ $(CXX) -c $(CXXFLAGS) -I$(INCDIR) $<
+
+ all: $(TARGET)
+
+ $(TARGET): $(MOCFILES) $(OBJECTS) lines.h
+- $(CC) $(OBJECTS) -o $(TARGET) $(LFLAGS) -I$(INCDIR)
++ $(CXX) $(OBJECTS) -o $(TARGET) $(LFLAGS) -I$(INCDIR)
+
+ lines.moc: lines.h
+ $(MOC) lines.h -o lines.moc