aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/angband/Makefile25
-rw-r--r--games/angband/distinfo8
-rw-r--r--games/angband/files/patch-docs_conf.py16
-rw-r--r--games/angband/pkg-plist28
4 files changed, 49 insertions, 28 deletions
diff --git a/games/angband/Makefile b/games/angband/Makefile
index f4a03d8634c2..343d56e358b5 100644
--- a/games/angband/Makefile
+++ b/games/angband/Makefile
@@ -1,12 +1,10 @@
# Created by: Matthew Hunt <mph@pobox.com>
PORTNAME= angband
-PORTVERSION= 4.1.3
+DISTVERSION= 4.2.2
+DISTNAME= Angband-${DISTVERSION}
CATEGORIES= games
-MASTER_SITES= http://rephial.org/downloads/${PORTVERSION:R}/
-
-PATCH_SITES= https://github.com/angband/angband/commit/
-PATCHFILES= 8702eba5c070a157dfc8e9d7c2106f679b7845c2.patch:-p1
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${DISTVERSION}/
MAINTAINER= adridg@FreeBSD.org
COMMENT= Rogue-like game with color, X11 support
@@ -19,12 +17,17 @@ CONFIGURE_ENV= ac_cv_path_NCURSES_CONFIG=${TRUE}
CONFIGURE_ARGS= --localstatedir=/var
CPPFLAGS+= -I${NCURSESINC}
-LDFLAGS+= -L${NCURSESLIB} -lncursesw
+LDFLAGS+= -Wl,--Bstatic -L${NCURSESLIB} -lncursesw -Wl,--Bdynamic
OPTIONS_DEFINE= SDL X11 DOCS
OPTIONS_DEFAULT=X11
-DOCS_BUILD_DEPENDS= rst2html:textproc/py-docutils
+# The docs as shipped want to use theme "better", but that's
+# not packaged in ports (yet); use rtd instead because it is.
+DOCS_USES= python:build
+DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR}
+
SDL_USES= sdl
SDL_USE= SDL=image,mixer,ttf,sdl
SDL_CONFIGURE_ENABLE= sdl
@@ -42,6 +45,14 @@ post-patch:
@${REINPLACE_CMD} -e \
's|-O0||' ${WRKSRC}/src/Makefile
+post-build-DOCS-on:
+ # Needs gmake, although we could run sphinx directly
+ cd ${WRKSRC}/docs && ${MAKE_CMD} singlehtml
+
+post-stage-DOCS-on:
+ mkdir -p ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/_build/singlehtml/index.html ${STAGEDIR}${DOCSDIR}/index.html
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/angband
.for i in user/save user/scores
diff --git a/games/angband/distinfo b/games/angband/distinfo
index a01ee18da629..5e87949497ef 100644
--- a/games/angband/distinfo
+++ b/games/angband/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1598552361
-SHA256 (angband-4.1.3.tar.gz) = 9402c4f8da691edbd4567a948c5663e1066bee3fcb4a62fbcf86b5454918406f
-SIZE (angband-4.1.3.tar.gz) = 19924395
-SHA256 (8702eba5c070a157dfc8e9d7c2106f679b7845c2.patch) = dec11e35e2f3f05b7185fc08e00e0da009ab55c79ee28819221347e259cbb797
-SIZE (8702eba5c070a157dfc8e9d7c2106f679b7845c2.patch) = 852
+TIMESTAMP = 1625176056
+SHA256 (Angband-4.2.2.tar.gz) = 679e2195cd3e62fdf427816183baad5c65f0b607031afbfeb5d83106b6e6ae36
+SIZE (Angband-4.2.2.tar.gz) = 24924454
diff --git a/games/angband/files/patch-docs_conf.py b/games/angband/files/patch-docs_conf.py
new file mode 100644
index 000000000000..e9238dff40a6
--- /dev/null
+++ b/games/angband/files/patch-docs_conf.py
@@ -0,0 +1,16 @@
+--- docs/conf.py.orig 2021-07-03 22:02:46 UTC
++++ docs/conf.py
+@@ -53,10 +53,10 @@ exclude_patterns = ["_build", "Thumbs.db", ".DS_Store"
+
+ # The theme to use for HTML and HTML Help pages. See the documentation for
+ # a list of builtin themes.
+-from better import better_theme_path
++from sphinx_rtd_theme import get_html_theme_path
+
+-html_theme_path = [better_theme_path]
+-html_theme = "better"
++html_theme_path = [get_html_theme_path()]
++html_theme = "sphinx_rtd_theme"
+
+ html_title = "<img> The Angband Manual"
+ html_short_title = "Home"
diff --git a/games/angband/pkg-plist b/games/angband/pkg-plist
index 386841ad833e..a5ccefeb3749 100644
--- a/games/angband/pkg-plist
+++ b/games/angband/pkg-plist
@@ -15,6 +15,7 @@
%%ETCDIR%%/gamedata/blow_methods.txt
%%ETCDIR%%/gamedata/body.txt
%%ETCDIR%%/gamedata/brand.txt
+%%ETCDIR%%/gamedata/chest_trap.txt
%%ETCDIR%%/gamedata/class.txt
%%ETCDIR%%/gamedata/constants.txt
%%ETCDIR%%/gamedata/curse.txt
@@ -29,22 +30,27 @@
%%ETCDIR%%/gamedata/names.txt
%%ETCDIR%%/gamedata/object.txt
%%ETCDIR%%/gamedata/object_base.txt
-%%ETCDIR%%/gamedata/object_power.txt
%%ETCDIR%%/gamedata/object_property.txt
%%ETCDIR%%/gamedata/p_race.txt
%%ETCDIR%%/gamedata/pain.txt
%%ETCDIR%%/gamedata/pit.txt
+%%ETCDIR%%/gamedata/player_property.txt
%%ETCDIR%%/gamedata/player_timed.txt
%%ETCDIR%%/gamedata/projection.txt
%%ETCDIR%%/gamedata/quest.txt
%%ETCDIR%%/gamedata/realm.txt
%%ETCDIR%%/gamedata/room_template.txt
+%%ETCDIR%%/gamedata/shape.txt
%%ETCDIR%%/gamedata/slay.txt
%%ETCDIR%%/gamedata/store.txt
%%ETCDIR%%/gamedata/summon.txt
%%ETCDIR%%/gamedata/terrain.txt
%%ETCDIR%%/gamedata/trap.txt
+%%ETCDIR%%/gamedata/ui_entry.txt
+%%ETCDIR%%/gamedata/ui_entry_base.txt
+%%ETCDIR%%/gamedata/ui_entry_renderer.txt
%%ETCDIR%%/gamedata/vault.txt
+%%ETCDIR%%/gamedata/visuals.txt
%%ETCDIR%%/gamedata/world.txt
%%DATADIR%%/fonts/10x14x.fon
%%DATADIR%%/fonts/10x14xb.fon
@@ -68,20 +74,9 @@
%%DATADIR%%/fonts/8x8xb.fon
%%DATADIR%%/fonts/9x15x.fon
%%DATADIR%%/fonts/9x15xb.fon
-%%DATADIR%%/help/attack.txt
-%%DATADIR%%/help/birth.txt
-%%DATADIR%%/help/command.txt
-%%DATADIR%%/help/copying.txt
-%%DATADIR%%/help/customize.txt
-%%DATADIR%%/help/debug.txt
-%%DATADIR%%/help/dungeon.txt
-%%DATADIR%%/help/general.txt
-%%DATADIR%%/help/help.hlp
+%%DATADIR%%/help/commands.txt
%%DATADIR%%/help/index.txt
-%%DATADIR%%/help/modifying.txt
-%%DATADIR%%/help/option.txt
-%%DATADIR%%/help/playing.txt
-%%DATADIR%%/help/version.txt
+%%DATADIR%%/help/symbols.txt
%%DATADIR%%/icons/angband-sdl.desktop
%%DATADIR%%/icons/angband-x11.desktop
%%DATADIR%%/icons/att-128.png
@@ -325,11 +320,12 @@
%%DATADIR%%/tiles/old/xtra-xxx.prf
%%DATADIR%%/tiles/shockbolt/64x64.png
%%DATADIR%%/tiles/shockbolt/flvr-shb.prf
-%%DATADIR%%/tiles/shockbolt/graf-shb.prf
+%%DATADIR%%/tiles/shockbolt/graf-shb-dark.prf
+%%DATADIR%%/tiles/shockbolt/graf-shb-light.prf
%%DATADIR%%/tiles/shockbolt/xtra-shb.prf
%%DATADIR%%/user/info/dummy.txt
%%DATADIR%%/user/info/user.hlp
-%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
@dir(,games,775) %%DATADIR%%/user
@dir(,games,775) %%DATADIR%%/user/info
@dir(,games,775) %%DATADIR%%/user/save