aboutsummaryrefslogtreecommitdiff
path: root/graphics/agave/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/agave/Makefile')
-rw-r--r--graphics/agave/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/graphics/agave/Makefile b/graphics/agave/Makefile
index 6460e6928898..60db3e752576 100644
--- a/graphics/agave/Makefile
+++ b/graphics/agave/Makefile
@@ -6,20 +6,22 @@
#
PORTNAME= colorscheme
-PORTVERSION= 0.3.1
+PORTVERSION= 0.3.91
CATEGORIES= graphics gnome
-MASTER_SITES= http://download.gna.org/${PORTNAME}/${PORTVERSION:S/.1$//}/
+MASTER_SITES= http://download.gna.org/${PORTNAME}/releases/
PKGNAMEPREFIX= gnome-
MAINTAINER= smyru@heron.pl
COMMENT= A color scheme builder for the GNOME desktop
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
- gnomevfsmm-2.6:${PORTSDIR}/devel/gnome-vfsmm \
- boost_thread.3:${PORTSDIR}/devel/boost \
- cppunit-1.10:${PORTSDIR}/devel/cppunit
+ gconfmm-2.6:${PORTSDIR}/devel/gconfmm26 \
+ boost_thread.3:${PORTSDIR}/devel/boost
+
+OPTIONS= GNOME "Adds GNOME support" on
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
@@ -27,4 +29,10 @@ GNU_CONFIGURE= yes
USE_GCC= 3.4+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GNOME)
+CONFIGURE_ARGS+= --disable-gnome --disable-gconf
+.endif
+
+.include <bsd.port.post.mk>