aboutsummaryrefslogtreecommitdiff
path: root/graphics/engauge-digitizer
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/engauge-digitizer')
-rw-r--r--graphics/engauge-digitizer/Makefile11
-rw-r--r--graphics/engauge-digitizer/pkg-descr2
2 files changed, 7 insertions, 6 deletions
diff --git a/graphics/engauge-digitizer/Makefile b/graphics/engauge-digitizer/Makefile
index 9eef73cbe1e9..cec4920d006a 100644
--- a/graphics/engauge-digitizer/Makefile
+++ b/graphics/engauge-digitizer/Makefile
@@ -1,11 +1,12 @@
PORTNAME= engauge-digitizer
DISTVERSIONPREFIX= v
DISTVERSION= 12.2.2
-PORTREVISION= 20
+PORTREVISION= 33
CATEGORIES= graphics math science
MAINTAINER= yuri@FreeBSD.org
COMMENT= Extract data points from images of graphs
+WWW= https://markummitchell.github.io/engauge-digitizer/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -15,19 +16,21 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
libopenjp2.so:graphics/openjpeg \
libpoppler-qt5.so:graphics/poppler-qt5
-USES= compiler:c++11-lang desktop-file-utils gl qmake qt:5
+USES= compiler:c++11-lang desktop-file-utils gl pkgconfig qmake qt:5 # pkgconfig is for https://github.com/markummitchell/engauge-digitizer/issues/423
USE_GITHUB= yes
GH_ACCOUNT= markummitchell
-USE_QT= core gui printsupport sql xml widgets buildtools_build
+USE_QT= core gui printsupport sql xml widgets buildtools:build
USE_GL= gl
CONFIGURE_ENV= OPENJPEG_INCLUDE=${PREFIX}/include/openjpeg-2.4 OPENJPEG_LIB=${PREFIX}/lib \
POPPLER_INCLUDE=${PREFIX}/include/poppler/qt5 POPPLER_LIB=${PREFIX}/lib
QMAKE_ARGS= "CONFIG+=jpeg2000 pdf"
+CXXFLAGS+= `pkg-config --cflags libopenjp2` # workaround for https://github.com/markummitchell/engauge-digitizer/issues/423
+
OPTIONS_DEFINE= NLS DOCS
OPTIONS_SUB= yes
-DOCS_USE= QT=help,linguist_build
+DOCS_USE= QT=help,linguist:build
do-patch-NLS-on:
@${REINPLACE_CMD} -e 's|QCoreApplication::applicationDirPath () + "/translations",|"${DATADIR}/translations",|' ${WRKSRC}/src/Translator/TranslatorContainer.cpp
diff --git a/graphics/engauge-digitizer/pkg-descr b/graphics/engauge-digitizer/pkg-descr
index 1abf7d483989..f7b1b9b237d1 100644
--- a/graphics/engauge-digitizer/pkg-descr
+++ b/graphics/engauge-digitizer/pkg-descr
@@ -5,5 +5,3 @@ Conceptually, Engauge Digitizer is the opposite of a graphing tool that converts
data points to graphs. The process is shown below - an image file is imported,
digitized within Engauge, and exported as a table of numeric data to a text
file. Work can be saved into an Engauge DIG file.
-
-WWW: http://markummitchell.github.io/engauge-digitizer/