aboutsummaryrefslogtreecommitdiff
path: root/graphics/engauge-digitizer
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/engauge-digitizer')
-rw-r--r--graphics/engauge-digitizer/Makefile45
-rw-r--r--graphics/engauge-digitizer/distinfo3
-rw-r--r--graphics/engauge-digitizer/pkg-descr9
-rw-r--r--graphics/engauge-digitizer/pkg-plist5
4 files changed, 62 insertions, 0 deletions
diff --git a/graphics/engauge-digitizer/Makefile b/graphics/engauge-digitizer/Makefile
new file mode 100644
index 000000000000..f5f5f136c3d9
--- /dev/null
+++ b/graphics/engauge-digitizer/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= engauge-digitizer
+DISTVERSIONPREFIX= v
+DISTVERSION= 10.7.6-2
+DISTVERSIONSUFFIX= -g7ce911c2
+CATEGORIES= graphics math science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Extract data points from images of graphs
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfftw3.so:math/fftw3 \
+ liblog4cpp.so:devel/log4cpp \
+ libopenjp2.so:graphics/openjpeg \
+ libpoppler-qt5.so:graphics/poppler-qt5
+
+USES= desktop-file-utils qmake
+USE_GITHUB= yes
+GH_ACCOUNT= markummitchell
+USE_QT5= core gui help printsupport sql xml widgets buildtools_build linguist_build
+USE_GL= gl
+CONFIGURE_ENV= OPENJPEG_INCLUDE=${PREFIX}/include/openjpeg-2.3 OPENJPEG_LIB=${PREFIX}/lib \
+ POPPLER_INCLUDE=${PREFIX}/include/poppler/qt5 POPPLER_LIB=${PREFIX}/lib
+QMAKE_ARGS= "CONFIG+=jpeg2000 pdf"
+
+OPTIONS_DEFINE= DOCS
+
+post-build:
+ @cd ${WRKSRC}/help && ./build
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/engauge ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+ ${GZIP_CMD} < ${WRKSRC}/src/img/${PORTNAME}.svg > ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}.svgz
+ ${INSTALL_DATA} ${WRKSRC}/dev/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/${PORTNAME}.desktop
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/documentation/engauge.qch ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/documentation/engauge.qhc ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/graphics/engauge-digitizer/distinfo b/graphics/engauge-digitizer/distinfo
new file mode 100644
index 000000000000..93a2b9349158
--- /dev/null
+++ b/graphics/engauge-digitizer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529465389
+SHA256 (markummitchell-engauge-digitizer-v10.7.6-2-g7ce911c2_GH0.tar.gz) = ce1ca9a91a4505adf91150c2abb037d1642558b1b02b2035a4e623dad7867647
+SIZE (markummitchell-engauge-digitizer-v10.7.6-2-g7ce911c2_GH0.tar.gz) = 68504322
diff --git a/graphics/engauge-digitizer/pkg-descr b/graphics/engauge-digitizer/pkg-descr
new file mode 100644
index 000000000000..1abf7d483989
--- /dev/null
+++ b/graphics/engauge-digitizer/pkg-descr
@@ -0,0 +1,9 @@
+The Engauge Digitizer tool accepts image files (like PNG, JPEG and TIFF)
+containing graphs, and recovers the data points from those graphs. The resulting
+data points are usually used as input to other software applications.
+Conceptually, Engauge Digitizer is the opposite of a graphing tool that converts
+data points to graphs. The process is shown below - an image file is imported,
+digitized within Engauge, and exported as a table of numeric data to a text
+file. Work can be saved into an Engauge DIG file.
+
+WWW: http://markummitchell.github.io/engauge-digitizer/
diff --git a/graphics/engauge-digitizer/pkg-plist b/graphics/engauge-digitizer/pkg-plist
new file mode 100644
index 000000000000..a4c6131f5067
--- /dev/null
+++ b/graphics/engauge-digitizer/pkg-plist
@@ -0,0 +1,5 @@
+bin/engauge
+share/icons/hicolor/scalable/apps/engauge-digitizer.svgz
+share/applications/engauge-digitizer.desktop
+%%PORTDOCS%%%%DOCSDIR%%/engauge.qch
+%%PORTDOCS%%%%DOCSDIR%%/engauge.qhc