aboutsummaryrefslogtreecommitdiff
path: root/graphics/geomorph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/geomorph/Makefile')
-rw-r--r--graphics/geomorph/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/geomorph/Makefile b/graphics/geomorph/Makefile
index 2650b7047d97..fa462d527dfa 100644
--- a/graphics/geomorph/Makefile
+++ b/graphics/geomorph/Makefile
@@ -31,6 +31,12 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+CFLAGS+= -O0
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|libpng|libpng12|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/local/share/geomorph/GeoMorph.xpm|geomorph.xpm|' \
@@ -49,4 +55,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/geomorph.desktop ${PREFIX}/share/applications/
${INSTALL_DATA} ${WRKSRC}/GeoMorph.xpm ${PREFIX}/share/pixmaps/geomorph.xpm
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>