aboutsummaryrefslogtreecommitdiff
path: root/graphics/maim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/maim/Makefile')
-rw-r--r--graphics/maim/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/maim/Makefile b/graphics/maim/Makefile
new file mode 100644
index 000000000000..f1a67e53e8b4
--- /dev/null
+++ b/graphics/maim/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= maim
+PORTVERSION= 2.3.31
+CATEGORIES= graphics
+
+MAINTAINER= neel@neelc.org
+COMMENT= Screenshot utility with performance improvements over scrot
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= naelstrof
+GH_PROJECT= maim
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 6888fa9
+
+USES= cmake
+USE_GCC= yes
+USE_EFL= imlib2
+USE_XORG= x11 xrandr xfixes
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/maim ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>