aboutsummaryrefslogtreecommitdiff
path: root/graphics/sane-backends/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/sane-backends/Makefile')
-rw-r--r--graphics/sane-backends/Makefile36
1 files changed, 12 insertions, 24 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index ffb745c30d20..b29778c28b50 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -2,33 +2,24 @@
# $FreeBSD$
PORTNAME= sane-backends
-PORTVERSION= 1.0.23
-PORTREVISION= 2
+PORTVERSION= 1.0.24
CATEGORIES= graphics
-MASTER_SITES= http://alioth.debian.org/frs/download.php/3752/:3752 \
- http://alioth.debian.org/frs/download.php/3753/:3753 \
- http://alioth.debian.org/frs/download.php/3754/:3754 \
- ftp://ftp2.sane-project.org/pub/sane/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}.1:3752,DEFAULT \
- ${DISTNAME}${EXTRACT_SUFX}.2:3753,DEFAULT \
- ${DISTNAME}${EXTRACT_SUFX}.3:3754,DEFAULT
-EXTRACT_ONLY= # need to concatenate before extraction
+MASTER_SITES= http://alioth.debian.org/frs/download.php/3958/ \
+ http://fossies.org/linux/misc/
MAINTAINER= ports@FreeBSD.org
COMMENT= API for access to scanners, digitals camera, frame grabbers etc
-LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
+LICENSE= GPLv2 # (or later)
LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libv4l1.so:${PORTSDIR}/multimedia/libv4l
OPTIONS_DEFINE= AVAHI CUPS DOCS GPHOTO IEEE1284 IPV6 NLS SNMP USB
-OPTIONS_DEFAULT= USB
+OPTIONS_DEFAULT= USB IPV6
OPTIONS_SUB= yes
-
+IEEE1284_DESC= Pararell port support via libieee1284
USB_DESC= USB support
-IEEE1284_DESC= libieee1284 support
USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
@@ -58,15 +49,15 @@ GPHOTO_LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
IEEE1284_LIB_DEPENDS= libieee1284.so:${PORTSDIR}/sysutils/libieee1284
-IPV6_CONFIGURE_OFF= --disable-ipv6
+IPV6_CONFIGURE_ENABLE= ipv6
-NLS_CONFIGURE_OFF= --disable-translations
+NLS_CONFIGURE_ENABLE= translations
NLS_USES= gettext
-SNMP_CONFIGURE_OFF= --without-snmp
+SNMP_CONFIGURE_WITH= snmp
SNMP_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
-USB_CONFIGURE_OFF= --disable-libusb
+USB_CONFIGURE_ENABLE= libusb
.include <bsd.port.options.mk>
@@ -84,8 +75,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e '/^for ac_header in/s|libc.h|cups/cups.h| ; \
- s|-e .*/cups.h|"$$ac_cv_header_cups_cups_h" = "yes"| ; \
- s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
+ s|-e .*/cups.h|"$$ac_cv_header_cups_cups_h" = "yes"|' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^dist_doc_DATA/s|COPYING||' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^pkgconfigdir/s|@libdir@|@prefix@/libdata|' \
@@ -93,7 +84,4 @@ post-patch:
@${REINPLACE_CMD} -e '/^export PKG_CONFIG_LIBDIR=/s|@libdir@|@prefix@/libdata|' \
${WRKSRC}/tools/sane-config.in
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>