aboutsummaryrefslogtreecommitdiff
path: root/graphics/wings-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/wings-devel/Makefile')
-rw-r--r--graphics/wings-devel/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/graphics/wings-devel/Makefile b/graphics/wings-devel/Makefile
deleted file mode 100644
index 1559bacbb52a..000000000000
--- a/graphics/wings-devel/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# New ports collection makefile for: wings
-# Date Created: 5 March 2003
-# Whom: olgeni@FreeBSD.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= wings
-PORTVERSION= 0.99.02
-CATEGORIES= graphics
-MASTER_SITES= SF
-DIST_SUBDIR= erlang
-
-MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= A polygon mesh modeler written in Erlang
-
-BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
- ${LOCALBASE}/lib/erlang/lib/esdl/include/sdl.hrl:${PORTSDIR}/devel/esdl
-RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
- ${LOCALBASE}/lib/erlang/lib/esdl/include/sdl.hrl:${PORTSDIR}/devel/esdl
-
-MAKE_ENV= ESDL_PATH=${LOCALBASE}/lib/erlang/lib/esdl
-PLIST_SUB= VERSION="${PORTVERSION}"
-
-SUB_FILES= wings.sh
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's|$$(GCC)|${CC} -I${LOCALBASE}/include -L${LOCALBASE}/lib|g' \
- ${WRKSRC}/plugins_src/accel/Makefile
-
-do-install:
- ${MKDIR} ${PREFIX}/lib/erlang/lib/${DISTNAME}
-.for dir in src ebin fonts plugins
- cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${PREFIX}/lib/erlang/lib/${DISTNAME}
-.endfor
- @${INSTALL_SCRIPT} ${WRKDIR}/wings.sh ${PREFIX}/bin/wings
- @${LN} -sf ${DISTNAME} ${PREFIX}/lib/erlang/lib/${PORTNAME}
-
-.include <bsd.port.mk>