aboutsummaryrefslogtreecommitdiff
path: root/graphics/zathura-ps/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/zathura-ps/Makefile')
-rw-r--r--graphics/zathura-ps/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/graphics/zathura-ps/Makefile b/graphics/zathura-ps/Makefile
index d5ae2891e281..0f2254ea8af5 100644
--- a/graphics/zathura-ps/Makefile
+++ b/graphics/zathura-ps/Makefile
@@ -1,6 +1,5 @@
PORTNAME= zathura-ps
-DISTVERSION= 0.2.6
-PORTREVISION= 4
+DISTVERSION= 0.2.7
CATEGORIES= graphics
MASTER_SITES= https://git.pwmt.org/pwmt/${PORTNAME}/-/archive/${DISTVERSION}/
@@ -11,16 +10,18 @@ WWW= https://pwmt.org/projects/zathura-ps/
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libspectre.so:print/libspectre
BUILD_DEPENDS= zathura:graphics/zathura
+LIB_DEPENDS= libgirara-gtk3.so:x11-toolkits/girara \
+ libspectre.so:print/libspectre
RUN_DEPENDS= zathura:graphics/zathura
USES= compiler:c11 desktop-file-utils gnome meson ninja pkgconfig ssl
-USE_GNOME= glib20 gtk30
+USE_GNOME= cairo glib20 gtk30
+USE_LDCONFIG= ${PREFIX}/lib/zathura
PLIST_FILES= lib/zathura/libps.so \
- share/applications/org.pwmt.zathura-ps.desktop \
- share/appdata/org.pwmt.zathura-ps.metainfo.xml
+ share/appdata/org.pwmt.zathura-ps.metainfo.xml \
+ share/applications/org.pwmt.zathura-ps.desktop
pre-configure:
${REINPLACE_CMD} "s:join_paths(datadir, 'metainfo'):join_paths(datadir, 'appdata'):" \