aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/maim/Makefile27
-rw-r--r--graphics/maim/distinfo2
-rw-r--r--graphics/maim/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 187608013892..dde6b8b74e0c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -580,6 +580,7 @@
SUBDIR += luminance-qt5
SUBDIR += luxrender
SUBDIR += mahotas
+ SUBDIR += maim
SUBDIR += makehuman
SUBDIR += mandelbulber
SUBDIR += mapnik
diff --git a/graphics/maim/Makefile b/graphics/maim/Makefile
new file mode 100644
index 000000000000..f1a67e53e8b4
--- /dev/null
+++ b/graphics/maim/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= maim
+PORTVERSION= 2.3.31
+CATEGORIES= graphics
+
+MAINTAINER= neel@neelc.org
+COMMENT= Screenshot utility with performance improvements over scrot
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= naelstrof
+GH_PROJECT= maim
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 6888fa9
+
+USES= cmake
+USE_GCC= yes
+USE_EFL= imlib2
+USE_XORG= x11 xrandr xfixes
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/maim ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/maim/distinfo b/graphics/maim/distinfo
new file mode 100644
index 000000000000..a27cd38ba0b9
--- /dev/null
+++ b/graphics/maim/distinfo
@@ -0,0 +1,2 @@
+SHA256 (maim-2.3.31.tar.gz) = cbfbf131ffb3e80cc72eec054d471320f2cd173e72344cbbdbf8839c83f968fe
+SIZE (maim-2.3.31.tar.gz) = 35868
diff --git a/graphics/maim/pkg-descr b/graphics/maim/pkg-descr
new file mode 100644
index 000000000000..170d4433b56b
--- /dev/null
+++ b/graphics/maim/pkg-descr
@@ -0,0 +1,5 @@
+maim (make image) takes screenshots of your desktop. maim is an
+improvement on Scrot, the minimalistic command line screen capturing
+application.
+
+WWW: http://www.github.com/naelstrof/maim