aboutsummaryrefslogtreecommitdiff
path: root/irc/polari/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/polari/Makefile')
-rw-r--r--irc/polari/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/irc/polari/Makefile b/irc/polari/Makefile
new file mode 100644
index 000000000000..e1be258a25e2
--- /dev/null
+++ b/irc/polari/Makefile
@@ -0,0 +1,27 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/irc/polari/Makefile 19991 2014-10-18 19:23:24Z gusi $
+
+PORTNAME= polari
+PORTVERSION= 3.14.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Internet Relay Chat (IRC) client designed for GNOME 3
+
+LIB_DEPENDS= libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib \
+ libgjs.so:${PORTSDIR}/lang/gjs
+
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack \
+ introspection:build
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>