aboutsummaryrefslogtreecommitdiff
path: root/japanese/mule-wnn7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/mule-wnn7/Makefile')
-rw-r--r--japanese/mule-wnn7/Makefile45
1 files changed, 25 insertions, 20 deletions
diff --git a/japanese/mule-wnn7/Makefile b/japanese/mule-wnn7/Makefile
index 69ffc4db5b93..10012424299f 100644
--- a/japanese/mule-wnn7/Makefile
+++ b/japanese/mule-wnn7/Makefile
@@ -1,23 +1,22 @@
-# New ports collection makefile for: mule
+# New ports collection makefile for: mule with Wnn
# Version required: 2.2.2
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.16 1995/04/20 18:23:06 asami Exp $
+# $Id: Makefile,v 1.17 1995/04/22 12:39:19 asami Exp $
#
-DISTNAME= mule-2.2.2
-CATEGORIES+= editors
-MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-DISTFILES= emacs-19.28.tar.gz
-
-# Use one of these if you are in Japan
-
-# PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
-# PATCHSITE= etlport.etl.go.jp:/pub/mule/
-
-PATCH_SITES= ftp.cs.buffalo.edu:/pub/mule/
-PATCHFILES= diff-19.28-2.2.gz patch-2.2.1.gz patch-2.2.2.gz
+DISTNAME= mule-2.2
+PKGNAME= jp-wmule-2.2.2
+CATEGORIES+= japanese editors
+MASTER_SITES= ftp://etlport.etl.go.jp/pub/mule/ \
+ ftp://ftp.cs.buffalo.edu/pub/mule/ \
+ ftp://sh.wide.ad.jp/JAPAN/mule/
+
+PATCH_SITES= ftp://etlport.etl.go.jp/pub/mule/ \
+ ftp://ftp.cs.buffalo.edu/pub/mule/ \
+ ftp://sh.wide.ad.jp/JAPAN/mule/
+PATCHFILES= patch-2.2.1.gz patch-2.2.2.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= asami@FreeBSD.ORG
@@ -26,22 +25,28 @@ MAINTAINER= asami@FreeBSD.ORG
DEPENDS= ${PORTSDIR}/japanese/Wnn
.endif
-WRKSRC= ${WRKDIR}/emacs-19.28
HAS_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
- --wnn --wnn-libraries=/usr/X11R6/lib \
- --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+ --wnn --wnn-libraries=/usr/X11R6/lib \
+ --wnn-includes=/usr/X11R6/include/wnn --terminal-face
STRIP=
pre-build:
find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
post-install:
-# note that any2ps is a script
- strip ${PREFIX}/bin/mule-19.28
- strip ${PREFIX}/bin/m2ps
+# note that rcs-checkn and any2ps are scripts
strip ${PREFIX}/bin/b2m
strip ${PREFIX}/bin/coco
+ strip ${PREFIX}/bin/ctags
+ strip ${PREFIX}/bin/etags
+ strip ${PREFIX}/bin/m2ps
+ strip ${PREFIX}/bin/mule-19.28
+ gzip -9nf ${PREFIX}/man/man1/coco.1
+ gzip -9nf ${PREFIX}/man/man1/ctags.1
+ gzip -9nf ${PREFIX}/man/man1/etags.1
+ gzip -9nf ${PREFIX}/man/man1/m2ps.1
+ gzip -9nf ${PREFIX}/man/man1/mule.1
.include <bsd.port.mk>