aboutsummaryrefslogtreecommitdiff
path: root/lang/cparser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/cparser/Makefile')
-rw-r--r--lang/cparser/Makefile33
1 files changed, 22 insertions, 11 deletions
diff --git a/lang/cparser/Makefile b/lang/cparser/Makefile
index 7fa482c95be3..04c2f95b06a8 100644
--- a/lang/cparser/Makefile
+++ b/lang/cparser/Makefile
@@ -1,33 +1,44 @@
-# New ports collection makefile for: libFIRM
-# Date created: 22 Nov 2008
-# Whom: Christoph Mallon <christoph.mallon@gmx.de>
-#
+# Created by: Christoph Mallon <christoph.mallon@gmx.de>
# $FreeBSD$
-#
PORTNAME= cparser
-PORTVERSION= 0.9.13
+PORTVERSION= 0.9.14
CATEGORIES= lang devel
MASTER_SITES= SF
-MAINTAINER= armin@frozen-zone.org
+MAINTAINER= sperber@FreeBSD.org
COMMENT= A C99 compiler using libFIRM as backend
LICENSE= GPLv2
-LIB_DEPENDS= firm.1:${PORTSDIR}/devel/libfirm
+LIB_DEPENDS= firm:${PORTSDIR}/devel/libfirm
USE_BZIP2= yes
USE_GMAKE= yes
+USES= pkgconfig
PLIST_FILES= bin/cparser
+MAN1= cparser.1
+
+BUILDDIR= optimize
+INSTALL_CMD= ${INSTALL_PROGRAM}
+
+OPTIONS_DEFINE= DEBUG
+
.include <bsd.port.pre.mk>
-MAN1= cparser.1
+.if ${PORT_OPTIONS:MDEBUG}
+BUILDDIR= debug
+INSTALL_CMD= ${INSTALL_PROGRAM:S,-s,,}
+.else
+post-patch:
+ @${REINPLACE_CMD} -e 's/^variant ?= debug/variant ?= optimize/' \
+ ${WRKSRC}/Makefile
+.endif
do-install:
- @${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/build/cparser ${PREFIX}/bin
- @${INSTALL_MAN} ${INSTALL_WRKSRC}/cparser.1 ${MAN1PREFIX}/man/man1
+ @${INSTALL_CMD} ${WRKSRC}/build/${BUILDDIR}/cparser ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/cparser.1 ${MAN1PREFIX}/man/man1
.include <bsd.port.post.mk>