aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc5-aux/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc5-aux/Makefile')
-rw-r--r--lang/gcc5-aux/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/lang/gcc5-aux/Makefile b/lang/gcc5-aux/Makefile
index 8dabf6396f5a..82fe94491e6c 100644
--- a/lang/gcc5-aux/Makefile
+++ b/lang/gcc5-aux/Makefile
@@ -27,6 +27,8 @@ BLD_TARGET= ${GARCH}-aux-${OPSYS:tl}${OSREL}
FULL_GNATGCC= NOT_SET
OS_LABEL4VERS= [${OPSYS}${GARCH:M*64:S/amd_//:S/x86_//}]
NO_MTREE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_GROUP= Standard Bootstrap
OPTIONS_GROUP_Standard= FORT OBJC NLS TESTSUITE STATIC
@@ -135,7 +137,7 @@ APPLY_DIFFS+= gcc-testsuite
.endif
.if ${PORT_OPTIONS:MNLS} && !${PORT_OPTIONS:MBOOTSTRAP}
-USES+= gettext-tools
+USES+= gettext
EXTRA_CONFIG+= --enable-nls
.else
EXTRA_CONFIG+= --disable-nls
@@ -156,7 +158,14 @@ EXTRA_CONFIG+= --with-boot-ldflags=-static
# Establish Ada-aware compiler for use
ADA_CONFIGURE_ENV+= CC=${FULL_GNATGCC}
ADA_CONFIGURE_ENV+= CXX=${FULL_GNATGXX}
+ADA_CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
+ADA_CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
+ADA_CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}"
+ADA_CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+ADA_CONFIGURE_ENV+= LIBS="${LIBS}"
ADA_CONFIGURE_ENV+= PATH=${FULL_PATH}
+ADA_CONFIGURE_ENV+= build_configargs="CPPFLAGS=\"${CPPFLAGS}\" LIBS=\"${LIBS}\""
+ADA_CONFIGURE_ENV+= host_configargs="CPPFLAGS=\"${CPPFLAGS}\" LIBS=\"${LIBS}\""
ADA_MAKE_ENV+= PATH=${FULL_PATH}
ADA_MAKE_ENV+= LD_LIBRARY_PATH=${BUILDDIR}/gcc