aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ghc/Makefile')
-rw-r--r--lang/ghc/Makefile17
1 files changed, 0 insertions, 17 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index be0afc3ede55..2510c0d17127 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -205,13 +205,6 @@ CONFIGURE_ARGS+= --with-ghc=${LOCALBASE}/bin/ghc
SLAVES_PREFIX= ${WRKDIR}/slaves_prefix
SLAVES_WRKDIRPREFIX= ${WRKDIR}/slaves_wrkdirprefix
-post-extract:
-# Use the "wrap" trick on arches that have to use pre-ino64 bootstrap binaries
-.if empty(PORT_OPTIONS:MBOOT) && ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200031 && \
- (${ARCH} == amd64 || ${ARCH} == i386)
- @${REINPLACE_CMD} -e 's|@SettingsCCompilerLinkFlags@|& -Wl,--wrap=readdir_r,--wrap=stat,--wrap=lstat,--wrap=fstat,--wrap=mknod|' ${BOOT_DIR}/settings.in
-.endif
-
# %%PORTDOCS%%%%DOCSDIR%%/html/libraries/doc-index-V.html
post-install-script:
${FIND} -ds ${GHC_LIBDIR} -type f -print | ${SED} -E \
@@ -262,16 +255,6 @@ pre-configure: apply-slist
# Copy the subbed build.mk to the proper position
${CP} ${WRKDIR}/build.mk ${WRKSRC}/mk/build.mk
-# Use the "wrap" trick on arches that have to use pre-ino64 bootstrap binaries
-.if empty(PORT_OPTIONS:MBOOT) && ${OPSYS} == FreeBSD && \
- ${OSVERSION} >= 1200031 && \
- (${ARCH} == amd64 || ${ARCH} == i386)
- ${CC} ${CFLAGS} -c -o ${BOOT_DIR}/wrap.o ${PATCHDIR}/wrap.c
- for x in ${BOOT_DIR}/rts/dist/build/libCffi*.a; do \
- ${AR} q $$x ${BOOT_DIR}/wrap.o; ${RANLIB} $$x; \
- done
- ${RM} ${BOOT_DIR}/wrap.o
-.endif
# If we are using bootstrap compiler, configure and install it into ${BOOT_DIR}
.if empty(PORT_OPTIONS:MBOOT)
cd ${BOOT_DIR} && ${CONFIGURE_ENV} ${CONFIGURE_CMD} --prefix=${BOOT_DIR}