aboutsummaryrefslogtreecommitdiff
path: root/lang/gnustep-base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gnustep-base/Makefile')
-rw-r--r--lang/gnustep-base/Makefile25
1 files changed, 7 insertions, 18 deletions
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 7194f12592d3..ccebc70f8d83 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -5,8 +5,7 @@ PORTNAME= gnustep-base
PORTVERSION= 1.24.6
PORTREVISION= 6
CATEGORIES= lang devel gnustep
-MASTER_SITES= ${MASTER_SITE_GNUSTEP}
-MASTER_SITE_SUBDIR= core
+MASTER_SITES= GNUSTEP/core
MAINTAINER= theraven@FreeBSD.org
COMMENT= GNUstep Foundation library
@@ -20,9 +19,7 @@ OPTIONS_DEFAULT= AVAHI
NOZEROCONF_DESC= Disable Zeroconf (Bonjour) support
AVAHI_DESC?= Zeroconf via Avahi (preferred)
-MDNS_DESC?= Zeroconf via Apple's mDNSResponder
-
-.include <bsd.port.options.mk>
+MDNS_DESC?= Zeroconf via mDNSResponder
LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
LIB_DEPENDS+= libxml2.so:${PORTSDIR}/textproc/libxml2
@@ -30,33 +27,27 @@ LIB_DEPENDS+= libxslt.so:${PORTSDIR}/textproc/libxslt
LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
LIB_DEPENDS+= libgnutls-openssl.so:${PORTSDIR}/security/gnutls
LIB_DEPENDS+= libicuuc.so:${PORTSDIR}/devel/icu
-LIB_DEPENDS+= libobjc.so.4.6:${PORTSDIR}/lang/libobjc2
LIB_DEPENDS+= libgcrypt.so:${PORTSDIR}/security/libgcrypt
-USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-procfs --disable-openssl --enable-tls \
--with-tls-prefix=${LOCALBASE} TLS_CONFIG="pkg-config -gnutls"\
--disable-mixedabi
CONFIGURE_ENV+= OBJCFLAGS='-fobjc-runtime=gnustep-1.7 -fblocks'
-USE_GNUSTEP= yes
-USE_GNUSTEP_CONFIGURE= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
-USES= pkgconfig iconv
+USES= pkgconfig iconv gnustep
+USE_GNUSTEP= build
+USE_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
-CFLAGS+= -I${LOCALBASE}/include/libxml2/libxml -DHAVE_DLADDR=1
-BREAKS_IF_PEDANTIC= yes
-PLIST_SUB+= LOCALBASE=${LOCALBASE}
ETCDIR= ${LOCALBASE}/etc
STAGEHEADER= ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Headers
PLIST_SUB+= BASEVERSION=${PORTVERSION:C/[.][0-9]*$//1}
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MAVAHI}
CONFIGURE_ARGS+= --with-zeroconf-api=avahi
LIB_DEPENDS+= libavahi-client.so:${PORTSDIR}/net/avahi-app
@@ -67,8 +58,6 @@ LIB_DEPENDS+= libdns_sd.so:${PORTSDIR}/net/mDNSResponder
CONFIGURE_ARGS+= --disable-zeroconf
.endif
-PATH:= ${PREFIX}/System/Tools:${PATH}
-
post-extract:
@${REINPLACE_CMD} -e "s|/usr/local/|${LOCALBASE}/|" \
${WRKSRC}/configure