aboutsummaryrefslogtreecommitdiff
path: root/lang/php70
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php70')
-rw-r--r--lang/php70/Makefile2
-rw-r--r--lang/php70/Makefile.ext27
2 files changed, 11 insertions, 18 deletions
diff --git a/lang/php70/Makefile b/lang/php70/Makefile
index 68eabe0f005d..f3c678f883d7 100644
--- a/lang/php70/Makefile
+++ b/lang/php70/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php70
PORTVERSION= 7.0.3
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php70/Makefile.ext b/lang/php70/Makefile.ext
index ae25af4718fa..ad0d0bebc9de 100644
--- a/lang/php70/Makefile.ext
+++ b/lang/php70/Makefile.ext
@@ -249,6 +249,16 @@ USE_PHP= pdo
USE_PHP_BUILD= yes
.endif
+.if ${PHP_MODNAME} == "pdo_mysql"
+OPTIONS_DEFINE= MYSQLND
+OPTIONS_DEFAULT=MYSQLND
+
+MYSQLND_DESC= Use MySQL Native Driver
+
+USE_PHP= pdo
+USE_PHP_BUILD= yes
+.endif
+
.if ${PHP_MODNAME} == "pdo_pgsql"
USES+= pgsql
@@ -530,17 +540,13 @@ CONFIGURE_ARGS+=--disable-mbregex
CONFIGURE_ARGS+=--with-mysqli=mysqlnd
. else
CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
-
USE_MYSQL= yes
. endif
.endif
.if ${PHP_MODNAME} == "pdo_mysql"
-USE_PHP=pdo
-USE_PHP_BUILD= yes
. if ${PORT_OPTIONS:MMYSQLND}
CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
-USE_PHP+= mysqli
. else
CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
--with-zlib-dir=/usr
@@ -561,19 +567,6 @@ LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif
.endif
-.if ${PHP_MODNAME} == "pdo_mysql"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
-
-USE_PHP+= mysql
-. else
-CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-
-USE_MYSQL= yes
-. endif
-.endif
-
.if ${PHP_MODNAME} == "xml"
post-extract:
@${MKDIR} ${WRKSRC}/ext/xml