aboutsummaryrefslogtreecommitdiff
path: root/lang/php82/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php82/Makefile')
-rw-r--r--lang/php82/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/lang/php82/Makefile b/lang/php82/Makefile
index ae4cdc3c2c66..bbceb4d67248 100644
--- a/lang/php82/Makefile
+++ b/lang/php82/Makefile
@@ -89,19 +89,8 @@ PHPDBG_VARS= PHP_SAPI+=phpdbg
ZTS_CONFIGURE_ON= --enable-zts
ZTS_CONFIGURE_ENV= pthreads_working="yes"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == riscv64
-CONFIGURE_ARGS+= --without-pcre-jit
-.endif
-
.if defined(PKGNAMEPREFIX)
USES+= apache
-.if ${PORT_OPTIONS:MAP2FILTER}
-CONFIGURE_ARGS+= --with-apxs2filter=${APXS}
-.else
-CONFIGURE_ARGS+= --with-apxs2=${APXS}
-.endif
PLIST= ${PKGDIR}/pkg-plist.mod
PKGMESSAGE= ${PKGDIR}/pkg-message.mod
MODULENAME= libphp
@@ -109,6 +98,12 @@ SHORTMODNAME= php
WARNING= "!!! If you have a threaded Apache, you must build ${PHP_PORT} with ZTS support to enable thread-safety in extensions !!!"
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == riscv64
+CONFIGURE_ARGS+= --without-pcre-jit
+.endif
+
.if ${PORT_OPTIONS:MPHPDBG} && ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-phpdbg-debug
.endif