aboutsummaryrefslogtreecommitdiff
path: root/lang/python37/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python37/Makefile')
-rw-r--r--lang/python37/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/python37/Makefile b/lang/python37/Makefile
index 1fbc864fc546..00715d704b09 100644
--- a/lang/python37/Makefile
+++ b/lang/python37/Makefile
@@ -30,7 +30,7 @@ PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
DISABLED_EXTENSIONS= _sqlite3 _tkinter _gdbm
CONFIGURE_ARGS+= --enable-shared --with-system-ffi --with-system-libmpdec --without-ensurepip
-CONFIGURE_ENV+= OPT="" DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS}" # Null out OPT to respect user CFLAGS and remove optimizations
+CONFIGURE_ENV+= OPT="" # Null out OPT to respect user CFLAGS and remove optimizations
INSTALL_TARGET= altinstall # Don't want cloberring of unprefixed files
@@ -111,6 +111,11 @@ post-patch:
# which introduces hidden dependency and breaks build
@${REINPLACE_CMD} -e 's|uuid/uuid.h|ignore_&|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/find_library_file/ s|uuid|ignore_&|' ${WRKSRC}/setup.py
+# Apply DISABLED_EXTENSIONS
+ @${ECHO} '*disabled*' > ${WRKSRC}/Modules/Setup.local
+. for _module in ${DISABLED_EXTENSIONS}
+ @${ECHO} ${_module} >> ${WRKSRC}/Modules/Setup.local
+. endfor
post-install:
.if ! ${PORT_OPTIONS:MDEBUG}