aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby20/Makefile')
-rw-r--r--lang/ruby20/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index 98eebf25a8d8..c66ecff5da18 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -19,9 +19,9 @@ LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
LICENSE_FILE_RUBY= ${WRKSRC}/COPYING
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
-BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
-LIB_DEPENDS= libyaml.so:${PORTSDIR}/textproc/libyaml
-RUN_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
+BUILD_DEPENDS= libffi>=0:devel/libffi
+LIB_DEPENDS= libyaml.so:textproc/libyaml
+RUN_DEPENDS= libffi>=0:devel/libffi
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
--disable-rpath \
@@ -59,15 +59,15 @@ RDOC_DESC= Build and install Rdoc indexes
EDIT_DESC= Which line editing lib to use
LIBEDIT_DESC= Use libedit
READLINE_DESC= Use libreadline
-CAPIDOCS_BUILD_DEPENDS= doxygen>0:${PORTSDIR}/devel/doxygen \
- dot:${PORTSDIR}/graphics/graphviz
+CAPIDOCS_BUILD_DEPENDS= doxygen>0:devel/doxygen \
+ dot:graphics/graphviz
CAPIDOCS_CONFIGURE_ENABLE= install-capi
LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-dir=${LOCALBASE}
LIBEDIT_USES= libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
-READLINE_BUILD_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
+READLINE_BUILD_DEPENDS= readline>=0:devel/readline
READLINE_CONFIGURE_ON= --disable-libedit --with-readline-dir=${LOCALBASE}
-READLINE_RUN_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
+READLINE_RUN_DEPENDS= readline>=0:devel/readline
CPE_VENDOR= ruby-lang
CPE_VERSION= ${RUBY_RELVERSION}