aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/ghc/Makefile29
-rw-r--r--lang/ghc/distinfo4
-rw-r--r--lang/ghc/files/wrap.c54
3 files changed, 6 insertions, 81 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 74986685a98d..19cb622afce0 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -31,13 +31,12 @@ SUB_LIST= GHC_VERSION=${GHC_VERSION} \
NCURSESINC="${NCURSESBASE}/include" NCURSESLIB="${NCURSESLIB}" \
CFLAGS="${CFLAGS}"
+OPTIONS_DEFINE= DYNAMIC GMP PROFILE DOCS
+OPTIONS_DEFAULT= DYNAMIC PROFILE GMP
+
OPTIONS_GROUP= BOOTSTRAP
BOOTSTRAP_DESC= Bootsrap using installed ghc
OPTIONS_GROUP_BOOTSTRAP=BOOT
-OPTIONS_DEFINE= DYNAMIC GMP PROFILE DOCS
-OPTIONS_SUB= yes
-
-OPTIONS_DEFAULT= DYNAMIC PROFILE GMP
BOOT_DESC= Use installed GHC for bootstrapping
DOCS_DESC= Install HTML documentation
@@ -78,6 +77,7 @@ LLVM_VERSION= 10
# LLVM version that bootstrap compiler uses
BOOT_LLVM_VERSION= 10
+OPTIONS_SUB= yes
PLIST_SUB= GHC_VERSION=${GHC_VERSION} CABAL_VERSION=${CABAL_VERSION}
PORTDOCS= *
@@ -91,18 +91,12 @@ CONFIGURE_TARGET= ${GHC_ARCH}-portbld-${OPSYS:tl}
BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libncursesw.so.8:misc/compat12x
.endif
-.if ${OSVERSION} >= 1400018
-CONFIGURE_ARGS+= --enable-dtrace=0
-.endif
-
.if ${ARCH} == aarch64 || ${ARCH:Marmv*}
BOOT_GHC_VERSION= 8.10.7
.else
BOOT_GHC_VERSION= 8.6.5
.endif
-NO_CCACHE= ccache: error: Failed to create directory /nonexistent/.ccache/tmp: Permission denied
-
DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
DATADIR= ${PREFIX}/share/ghc-${GHC_VERSION}
EXAMPLESDIR= ${PREFIX}/share/examples/ghc-${GHC_VERSION}
@@ -128,8 +122,7 @@ _EXECUTABLES+= ${GHC_LIBDIR}/bin/ghc-iserv-dyn
.endif
.if empty(PORT_OPTIONS:MBOOT)
-BOOTSTRAPS_SUFFIX?= ${BOOTSTRAPS_SUFFIX_${ARCH}}
-DISTFILES+= ghc-${BOOT_GHC_VERSION}-boot-${ARCH}-freebsd${BOOTSTRAPS_SUFFIX}${EXTRACT_SUFX}:boot
+DISTFILES+= ghc-${BOOT_GHC_VERSION}-boot-${ARCH}-freebsd${EXTRACT_SUFX}:boot
.endif # MBOOT
.if ${ARCH} == aarch64 || ${ARCH:Marmv*}
@@ -147,12 +140,6 @@ BUILD_DEPENDS+= llc${BOOT_LLVM_VERSION}:devel/llvm${BOOT_LLVM_VERSION}
. endif
.endif
-.if ${ARCH} == aarch64 || ${ARCH:Marmv*}
-. ifdef QEMU_EMULATING
-IGNORE= qemu-user-static isn't able to build lang/ghc, but it builds fine on a real hardware
-. endif
-.endif
-
.if empty(PORT_OPTIONS:MBOOT)
BOOT_DIR= ${WRKDIR}/ghc-${BOOT_GHC_VERSION}-boot
BOOT_GHC= ${BOOT_DIR}/bin/ghc-${BOOT_GHC_VERSION}
@@ -186,12 +173,8 @@ pre-configure:
.if empty(PORT_OPTIONS:MBOOT)
cd ${BOOT_DIR} && ${CONFIGURE_ENV} ${CONFIGURE_ENV_BOOTSTRAP} ${CONFIGURE_CMD} --prefix=${BOOT_DIR}
cd ${BOOT_DIR} && PACKAGES='' ${MAKE_CMD} install
-.else
-# otherwise, make sure we have "ghc" in PATH
- if ! ${WHICH} -s ghc ; then \
- echo "No 'ghc' executable is found in your PATH! Turn off BOOT option." ; false ; \
- fi
.endif
+
# If DOCS are set, install HsColour in-place
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${SLAVES_PREFIX}
diff --git a/lang/ghc/distinfo b/lang/ghc/distinfo
index 187690e5a767..4e2df2421ba6 100644
--- a/lang/ghc/distinfo
+++ b/lang/ghc/distinfo
@@ -5,10 +5,6 @@ SHA256 (ghc-8.6.5-boot-amd64-freebsd.tar.xz) = aeaf8c0fee0d83de5088aa7ab92e92ee6
SIZE (ghc-8.6.5-boot-amd64-freebsd.tar.xz) = 70213260
SHA256 (ghc-8.6.5-boot-i386-freebsd.tar.xz) = 47cc24cdcfa19601bb81a7f5660d1d72fec1110119e8ffe1daa0cddc7959206f
SIZE (ghc-8.6.5-boot-i386-freebsd.tar.xz) = 67522080
-SHA256 (ghc-8.6.5-boot-amd64-freebsd11.tar.xz) = 07d4c54a70900128e24b5dd9b22d929ddcf530d911a8be93e694cd9a721f458a
-SIZE (ghc-8.6.5-boot-amd64-freebsd11.tar.xz) = 68965716
-SHA256 (ghc-8.6.5-boot-i386-freebsd11.tar.xz) = cd208fbb6b2a158ff8c5d6227e0babd8c224867ea301abf970dc446f04c9e95f
-SIZE (ghc-8.6.5-boot-i386-freebsd11.tar.xz) = 67439136
SHA256 (ghc-8.10.4-boot-armv6-freebsd.tar.xz) = 04b207b787bdff71028b8d4c311a47105d7b098809e8fd21b788b1ab0dccdf22
SIZE (ghc-8.10.4-boot-armv6-freebsd.tar.xz) = 148679080
SHA256 (ghc-8.10.4-boot-armv7-freebsd.tar.xz) = db94e69b83a93fba9c136e890ccb0bf76b6d163ac3979dadb1568e81c3267744
diff --git a/lang/ghc/files/wrap.c b/lang/ghc/files/wrap.c
deleted file mode 100644
index cf0ed7802ee6..000000000000
--- a/lang/ghc/files/wrap.c
+++ /dev/null
@@ -1,54 +0,0 @@
-/* -*- ugly-hack-mode -*- */
-
-#include <sys/stat.h>
-
-struct old_dirent;
-struct old_stat;
-
-__asm(".symver old_readdir_r, readdir_r@FBSD_1.0");
-int old_readdir_r(void *dirp, struct old_dirent *entry,
- struct old_dirent **result);
-__asm(".symver old_stat, stat@FBSD_1.0");
-int old_stat(const char * restrict path, struct old_stat * restrict sb);
-__asm(".symver old_lstat, lstat@FBSD_1.0");
-int old_lstat(const char * restrict path, struct old_stat * restrict sb);
-__asm(".symver old_fstat, fstat@FBSD_1.0");
-int old_fstat(int fd, struct old_stat *sb);
-__asm(".symver old_mknod, mknod@FBSD_1.0");
-int old_mknod(const char *path, mode_t mode, uint32_t dev);
-
-int
-__wrap_readdir_r(void *dirp, struct old_dirent *entry,
- struct old_dirent **result)
-{
-
- return (old_readdir_r(dirp, entry, result));
-}
-
-int
-__wrap_stat(const char * restrict path, struct old_stat * restrict sb)
-{
-
- return (old_stat(path, sb));
-}
-
-int
-__wrap_lstat(const char * restrict path, struct old_stat * restrict sb)
-{
-
- return (old_lstat(path, sb));
-}
-
-int
-__wrap_fstat(int fd, struct old_stat *sb)
-{
-
- return (old_fstat(fd, sb));
-}
-
-int
-__wrap_mknod(const char *path, mode_t mode, uint32_t dev)
-{
-
- return (old_mknod(path, mode, dev));
-}