aboutsummaryrefslogtreecommitdiff
path: root/mail/queue-repair
diff options
context:
space:
mode:
Diffstat (limited to 'mail/queue-repair')
-rw-r--r--mail/queue-repair/Makefile7
-rw-r--r--mail/queue-repair/pkg-descr2
-rw-r--r--mail/queue-repair/pkg-plist6
3 files changed, 6 insertions, 9 deletions
diff --git a/mail/queue-repair/Makefile b/mail/queue-repair/Makefile
index f4326d1afb62..45d15787cad4 100644
--- a/mail/queue-repair/Makefile
+++ b/mail/queue-repair/Makefile
@@ -20,7 +20,8 @@ USE_QMAIL_RUN= yes
USE_PYTHON= yes
-DOCS= BLURB CHANGELOG TODO
+PLIST_FILES= bin/queue-repair
+PORTDOCS= BLURB CHANGELOG TODO
do-build:
${REINPLACE_CMD} -e 's,^#!/usr/bin/python,#!${PYTHON_CMD},' \
@@ -33,7 +34,9 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/queue_repair.py ${PREFIX}/bin/queue-repair
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
.endif
.include <bsd.port.mk>
diff --git a/mail/queue-repair/pkg-descr b/mail/queue-repair/pkg-descr
index f9af281c9fca..0b7924f1e849 100644
--- a/mail/queue-repair/pkg-descr
+++ b/mail/queue-repair/pkg-descr
@@ -16,4 +16,4 @@ queue_repair features include:
- can run in repair or test (report-only) modes. The default is test mode.
-WWW: http://www.qcc.ca/~charlesc/software/queue_repair/
+WWW: http://pyropus.ca/software/queue-repair/
diff --git a/mail/queue-repair/pkg-plist b/mail/queue-repair/pkg-plist
deleted file mode 100644
index b2fcdb7e21c4..000000000000
--- a/mail/queue-repair/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-@comment $FreeBSD$
-bin/queue-repair
-%%PORTDOCS%%%%DOCSDIR%%/BLURB
-%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%@dirrm %%DOCSDIR%%