aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/drac/Makefile101
-rw-r--r--mail/drac/distinfo2
-rw-r--r--mail/drac/files/dracd.in28
-rw-r--r--mail/drac/files/patch-Makefile45
-rw-r--r--mail/drac/files/patch-rpc.dracd.1m31
-rw-r--r--mail/drac/files/patch-rpc.dracd.c20
-rw-r--r--mail/drac/files/patch-testing.c10
-rw-r--r--mail/drac/pkg-descr12
9 files changed, 0 insertions, 250 deletions
diff --git a/mail/Makefile b/mail/Makefile
index e1de29ca9996..f943fe7e36d9 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -99,7 +99,6 @@
SUBDIR += dovecot-pigeonhole
SUBDIR += dovecot-pigeonhole04
SUBDIR += dovecot22
- SUBDIR += drac
SUBDIR += dspam
SUBDIR += ecartis
SUBDIR += elm
diff --git a/mail/drac/Makefile b/mail/drac/Makefile
deleted file mode 100644
index 3cfdcdd58d24..000000000000
--- a/mail/drac/Makefile
+++ /dev/null
@@ -1,101 +0,0 @@
-# Created by: Anders Nordby <anders@fix.no>
-# $FreeBSD$
-
-PORTNAME= drac
-PORTVERSION= 1.12
-PORTREVISION= 9
-CATEGORIES= mail
-MASTER_SITES= ftp://ftp.cc.umanitoba.ca/src/ \
- http://atreides.freenix.no/~anders/ \
- ftp://totem.fix.no/pub/mirrors/misc/
-DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .tar.Z
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Dynamic Relay Authorization Control, a POP-before-SMTP implementation
-
-DEPRECATED= Unmaintained upstream since 2003
-EXPIRATION_DATE= 2019-01-15
-
-PLIST_FILES= sbin/rpc.dracd include/drac.h lib/libdrac.a \
- etc/dracd.allow-sample
-
-USE_CSTD= gnu89
-
-MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= DB DOCS IPV6
-OPTIONS_RADIO= MUA
-OPTIONS_RADIO_MUA= POSTFIX EXIM
-POSTFIX_DESC= Use POSTFIX
-EXIM_DESC= Use EXIM
-DB_DESC= Use database with POSTFIX
-
-.include <bsd.port.options.mk>
-
-DEFS= -DWITH_TI_RPC -DFLOCK_LOCK -DGETHOST -DDASH_C
-
-.if ${PORT_OPTIONS:MPOSTFIX}
-DEFS+= -DTERM_KD
-RUN_DEPENDS+= postfix:mail/postfix
-.if ${PORT_OPTIONS:MDB}
-USES+= bdb
-.endif
-.elif ${PORT_OPTIONS:MEXIM}
-DEFS+= -DTERM_KD -DREQ_HASH -DCIDR_KEY
-RUN_DEPENDS+= exim:mail/exim
-.endif
-
-NO_WRKSUBDIR= yes
-USE_RC_SUBR= dracd
-
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_FILES+= man/man3/dracauth.3.gz man/man1/rpc.dracd.1.gz
-.endif
-
-.if defined(WITH_TI_RPC)
-DEFS+= -DTI_RPC
-.else
-DEFS+= -DSOCK_RPC
-.endif
-
-.if defined(WITH_FOREGROUND)
-DEFS+= -DRPC_SVC_FG
-.endif
-
-MAKE_ARGS+= DEFS="${DEFS}"
-
-pre-everything::
-.if ${PORT_OPTIONS:MIPV6}
- @${ECHO_MSG} "============================================================="
- @${ECHO_MSG} "It is IPv6 non-correspondence."
- @${ECHO_MSG} "After it understands, it is possible to use it with IPv4."
- @${ECHO_MSG} "============================================================="
- @${ECHO_MSG}
-.endif
- @${ECHO_MSG} "============================================================="
- @${ECHO_MSG} "For databases compatible with other MTAs than sendmail, use:"
- @${ECHO_MSG}
- @${ECHO_MSG} "mail/postfix"
- @${ECHO_MSG} "mail/exim"
- @${ECHO_MSG}
- @${ECHO_MSG} "Define WITH_FOREGROUND to make the rpc.dracd daemon stay in"
- @${ECHO_MSG} "foreground instead of detaching itself. This breaks the"
- @${ECHO_MSG} "startup script."
- @${ECHO_MSG} "============================================================="
-
-post-patch:
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/rpc.dracd.1m
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/rpc.dracd ${STAGEDIR}${PREFIX}/sbin/
- @${INSTALL_DATA} ${WRKSRC}/drac.h ${STAGEDIR}${PREFIX}/include/
- @${INSTALL_DATA} ${WRKSRC}/libdrac.a ${STAGEDIR}${PREFIX}/lib/
- @${INSTALL_DATA} ${WRKSRC}/dracd.allow-sample \
- ${STAGEDIR}${PREFIX}/etc/
-.if ${PORT_OPTIONS:MDOCS}
- @${INSTALL_MAN} ${WRKSRC}/dracauth.3 ${STAGEDIR}${PREFIX}/man/man3/
- @${INSTALL_MAN} ${WRKSRC}/rpc.dracd.1m \
- ${STAGEDIR}${PREFIX}/man/man1/rpc.dracd.1
-.endif
-
-.include <bsd.port.mk>
diff --git a/mail/drac/distinfo b/mail/drac/distinfo
deleted file mode 100644
index ce952259c1ff..000000000000
--- a/mail/drac/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (drac.tar.Z) = 2c184de422ae4b347464de5083c38cb8d3ab4d53b6584514c7a5bd67870729db
-SIZE (drac.tar.Z) = 20705
diff --git a/mail/drac/files/dracd.in b/mail/drac/files/dracd.in
deleted file mode 100644
index 5d95021135b3..000000000000
--- a/mail/drac/files/dracd.in
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-#
-# PROVIDE: dracd
-# REQUIRE: DAEMON
-# BEFORE: LOGIN
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf to enable postfix:
-# dracd_enable (bool): Set it to "YES" to enable rpc.dracd.
-# Default is "NO".
-# dracd_flags (str): Set to "" by default.
-# Extra flags passed to rpc.dracd.
-#
-
-. /etc/rc.subr
-
-name="dracd"
-rcvar=dracd_enable
-command="%%PREFIX%%/sbin/rpc.dracd"
-
-load_rc_config $name
-
-: ${dracd_enable="NO"}
-
-required_files="%%PREFIX%%/etc/dracd.allow"
-
-run_rc_command "$1"
diff --git a/mail/drac/files/patch-Makefile b/mail/drac/files/patch-Makefile
deleted file mode 100644
index 6ca9088fb3dc..000000000000
--- a/mail/drac/files/patch-Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
---- Makefile.orig 2003-01-12 21:45:12.000000000 +0100
-+++ Makefile 2014-04-04 23:35:46.000000000 +0200
-@@ -5,9 +5,11 @@
-
- # Paths
-
--INSTALL = /usr/ucb/install
--EBIN = /usr/local/sbin
--MAN = /usr/local/man/man
-+INSTALL? = install
-+EBIN = ${PREFIX}/sbin
-+MAN = ${PREFIX}/man/man
-+ETC_DIR = ${PREFIX}/etc
-+DEFS = ${DEFS}
-
- # OS-Dependant settings
-
-@@ -33,22 +35,19 @@
- # -DCIDR_KEY # keys in CIDR format
- # -DTERM_KD # keys and data nul-terminated
-
--DEFS = -DTI_RPC -DFCNTL_LOCK -DSYSINFO
--
- # Compiler flags
--CC = cc
-+CC? = cc
- RANLIB = :
--CFLAGS = $(DEFS) -g -I/usr/local/src/db/db-4.1.25/build_unix
-+CFLAGS+= $(DEFS) -g -I${PREFIX}/include -DDBFILE=\"$(ETC_DIR)/dracd.db\" -DALFILE=\"$(ETC_DIR)/dracd.allow\"
- #CFLAGS = $(DEFS) -g -I/usr/local/src/db/db-3.1.17/build_unix
- #CFLAGS = $(DEFS) -g -I/usr/local/src/db/db-2.4.14/Unix
- #CFLAGS = $(DEFS) -g -I/usr/local/src/db/db.1.85/PORT/sunos.5.2/include
--LDLIBS = -L/usr/local/src/db/db-4.1.25/build_unix -lnsl -ldb-4.1
-+LDLIBS =
- #LDLIBS = -L/usr/local/src/db/db-3.1.17/build_unix -lnsl -ldb
- #LDLIBS = -L/usr/local/src/db/db-2.4.14/Unix -lnsl -ldb
- #LDLIBS = -L/usr/local/src/db/db.1.85/PORT/sunos.5.2 -lnsl -ldb
--TSTLIBS = -L. -ldrac -lnsl
--RPCGENFLAGS =
--#RPCGENFLAGS = -C
-+TSTLIBS = -L. -ldrac
-+RPCGENFLAGS = -C -I
-
- # Man sections
- MANLIB = 3
diff --git a/mail/drac/files/patch-rpc.dracd.1m b/mail/drac/files/patch-rpc.dracd.1m
deleted file mode 100644
index 8868dd82e8ba..000000000000
--- a/mail/drac/files/patch-rpc.dracd.1m
+++ /dev/null
@@ -1,31 +0,0 @@
---- rpc.dracd.1m.old Sun Jan 14 19:18:52 2001
-+++ rpc.dracd.1m Sun Jan 14 19:19:28 2001
-@@ -16,13 +16,13 @@
- \f4rpc.dracd\f1
- is the Dynamic Relay Authorization Control server.
- It uses the Berkeley db package to maintain a relay authorization
--map for sendmail, by default \f4/etc/mail/dracd.db\f1.
-+map for sendmail, by default \f4%%PREFIX%%/etc/dracd.db\f1.
- POP and IMAP mail servers make an RPC call to add an entry to the
- authorization cache after they have authenticated each user.
- The daemon, rpc.dracd, adds or updates entries in the cache, and
- periodically expires old entries.
- Only trusted mail servers are permitted to communicate with rpc.dracd,
--as controlled by \f4/etc/mail/dracd.allow\f1.
-+as controlled by \f4%%PREFIX%%/etc/dracd.allow\f1.
- If this file does not exist, all local IP addresses are permitted.
- .SS Allow File Format
- The Allow File file consists of entries of the form:
-@@ -58,10 +58,10 @@
- .SH FILES
- .PD 0
- .TP 30
--.B /etc/mail/dracd.db
-+.B %%PREFIX%%/etc/dracd.db
- default database file
- .TP
--.B /etc/mail/dracd.allow
-+.B %%PREFIX%%/etc/dracd.allow
- default allow file.
- .PD
- .SH SEE ALSO
diff --git a/mail/drac/files/patch-rpc.dracd.c b/mail/drac/files/patch-rpc.dracd.c
deleted file mode 100644
index 0550d5159b65..000000000000
--- a/mail/drac/files/patch-rpc.dracd.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- rpc.dracd.c.orig Tue Nov 21 05:22:05 2000
-+++ rpc.dracd.c Sun Apr 29 20:41:31 2001
-@@ -8,7 +8,6 @@
- #include <errno.h>
- #include <syslog.h>
- #ifdef TI_RPC
--#include <netdir.h>
- #include <netconfig.h>
- #endif
- #include <stdlib.h>
-@@ -35,9 +34,6 @@
- #define DB_VERSION_MAJOR 1
- #endif
- #include "drac.h"
--
--#define DBFILE "/etc/mail/dracd.db"
--#define ALFILE "/etc/mail/dracd.allow"
-
- struct net_def {
- struct net_def *nd_next;
diff --git a/mail/drac/files/patch-testing.c b/mail/drac/files/patch-testing.c
deleted file mode 100644
index fc9b9d64f68a..000000000000
--- a/mail/drac/files/patch-testing.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- testing.c.orig 1998-08-10 18:36:14.000000000 -0700
-+++ testing.c 2008-06-04 04:50:08.000000000 -0700
-@@ -3,6 +3,7 @@
- */
-
- #include <stdio.h>
-+#include <stdlib.h>
- #include <sys/types.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
diff --git a/mail/drac/pkg-descr b/mail/drac/pkg-descr
deleted file mode 100644
index b130738d70a9..000000000000
--- a/mail/drac/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-DRAC is a daemon that dynamically updates a relay authorization map for
-Sendmail, Postfix and other MTAs that support it. It provides a way for
-legitimate users to relay mail through an SMTP server, while preventing
-non-authorized users from using it as a spam relay. Authenticated users
-have their IP address added to the map immediately after they have
-authenticated via POP, IMAP, or any other daemon which supports the
-DRAC API. By default, map entries expire after 30 minutes, but can be
-renewed by additional authentication. Periodically checking mail on a
-POP server sufficiently does this. DRAC does not require that the
-POP/IMAP and SMTP server be on the same physical host.
-
-WWW: http://mail.cc.umanitoba.ca/drac/