aboutsummaryrefslogtreecommitdiff
path: root/math/hs-Agda/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/hs-Agda/Makefile')
-rw-r--r--math/hs-Agda/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile
index 752cb0f7f1a9..c6ac1f1ad953 100644
--- a/math/hs-Agda/Makefile
+++ b/math/hs-Agda/Makefile
@@ -2,31 +2,36 @@
# $FreeBSD$
PORTNAME= Agda
-PORTVERSION= 2.4.0.2
-PORTREVISION= 1
+PORTVERSION= 2.4.2.3
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Dependently typed functional programming language and proof assistant
-USE_CABAL= boxes>=0.1.3 data-hash>=0.2.0.0 equivalence>=0.2.4 \
- geniplate>=0.6.0.3 hashable hashtables>=1.0 \
- haskell-src-exts>=1.9.6 mtl>=2.1.1 parallel QuickCheck>=2.6 \
- STMonadTrans>=0.3.2 strict>=0.3.2 text>=0.11 \
+USE_CABAL= base-orphans>=0.3.1 boxes>=0.1.3 cpphs data-hash>=0.2.0.0 \
+ edit-distance>=0.2.1.2 equivalence>=0.2.5 \
+ geniplate-mirror>=0.6.0.6 hashable>=1.1.2.3 hashtables>=1.0 \
+ haskell-src-exts>=1.16.0.1 mtl>=2.1.1 parallel QuickCheck>=2.8 \
+ strict>=0.3.2 text>=0.11 transformers-compat>=0.3.3.2 \
unordered-containers>=0.2 zlib>=0.4.0.1
+
USE_ALEX= yes
USE_HAPPY= yes
USES= iconv:translit
EXECUTABLE= agda-mode agda
-INSTALL_PORTDATA= cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DATADIR}
+_PRIMITIVE= Primitive.agdai
-FLAGS_DEFINE= EPIC
+INSTALL_PORTDATA= ${INSTALL_DATA} \
+ ${DISTDIR}/${DIST_SUBDIR}/${_PRIMITIVE}.${PORTVERSION} \
+ ${STAGEDIR}${DATADIR}/lib/prim/Agda/${_PRIMITIVE}
-EPIC_DESC= Install the Epic compiler
-EPIC_FLAG_ENABLE= epic
-EPIC_FLAG_CABAL= epic>=0.1.13
+FLAGS_ENABLE= cpphs
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+
+MASTER_SITES+= LOCAL/pgj:primitive
+DISTFILES+= ${_PRIMITIVE}.${PORTVERSION}:primitive
+
.include <bsd.port.mk>