aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-coder/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-coder/Makefile')
-rw-r--r--math/octave-forge-coder/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/math/octave-forge-coder/Makefile b/math/octave-forge-coder/Makefile
index 21aa004127a7..0d5ef2ce693a 100644
--- a/math/octave-forge-coder/Makefile
+++ b/math/octave-forge-coder/Makefile
@@ -8,27 +8,20 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
WWW= https://packages.octave.org/
LICENSE= GPLv3
-LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+LICENSE_FILE= ${WRKDIR}/${OCTAVE_SRC}/COPYING
+USES= octave
USE_GITHUB= yes
GH_ACCOUNT= shsajjadi
GH_PROJECT= OctaveCoder
-# OCTSRC is the name of the directory of the package.
-# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
-OCTSRC= ${GH_PROJECT}-coder-${DISTVERSION}
+OCTAVE_SRC= ${GH_PROJECT}-coder-${DISTVERSION}
-WRKSRC= ${WRKDIR}/${OCTSRC}
-
-.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+WRKSRC= ${WRKDIR}/${OCTAVE_SRC}
do-build:
cd ${WRKSRC} && \
octave-cli -W -H -q --no-site-file --eval "pre_install" && \
${RM} pre_install.m
-post-build:
- ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
-
.include <bsd.port.mk>